MDS CPU bug present and SMT on, data leak possible in HOST log

hi !

i’ve just moved HASS on a laptop to have more power (before VM on a QNAP NAS)
but i’ve noticed this warning in the CORE log

MDS CPU bug present and SMT on, data leak possible. See MDS - Microarchitectural Data Sampling — The Linux Kernel documentation for more details.

and i’ve only 1 CPU activated … 50% of loss … :frowning:

the link and other research say to modify the boot command to resolve or force.
but is it possible with HASS ?


I assume you mean home assistant operating system? If the only thing you are running on the laptop is HA.OS, you can safely ignore that error in almost all cases, the main threat would be virtualized addons, and only if the communicate with an external host, and only if they are malicious, and honestly there are far easier ways to attack HA than MDS, so I would just ignore the message.

Disabling SMT still does not fix MDS, it only makes it harder, and SMT does not double performance, on average you may loose 15-20% not 50%, though it can have a higher max performance hit on a cpu with 1 physical core, like it sounds you have.

yes, thats it : only HA OS on the laptop.

i only want to test the options on the mds value in the kernel command line but i dont know how to do this in HA OS.

the cpu is an old i5-2410m
2 cores, 4thread … and only 1 core activated in fact

well, no one got and idea of how to configure HA.OS to force SMT usage to “on”

if it is actually turning off smt using a kernel config flag, you need to modify the bootloader config file to make it permanent, or if you can get a terminal window you can do:

echo on > /sys/devices/system/cpu/smt/control

I’ve tried a cat before : it’s allready on.
But during the boot process, the MDS bug is detected and only 1 CPU core is activated.
And i suppose that modifying bootloader config file in HASS.OS is not allowed.

I’ve another anoying with the laptop : the integrated LCD panel is allways on …

so … i’m going to migrate on an ODROID …