Media Browser Cameras all Incompatible

The new Media Browser Integration is a beautiful addition for google home and chromecast users. When you launch it, by default, you are presented with 3 media source options: Camera, Local Media, and Text to Speech. They all seem to work EXCEPT the camera option, how do you use this? I have cameras added to HA as amcrest, onvif, and platform:generic. I’ve tried setting my rtsp streams to both internal IPs and external URLs using my external domain.com DNS redirects. Nothing works. Is this even supported yet? Surely if this “Camera” tile is here, it must work with something?


.
.
.

I have the exact same issue… did you get any further?

Not really, still stuck in the same position. Hoping one of the devs can chime in to explain what that button is for or why they added it.

Same for me

I have the same error with stored media and can only assume its something to do with the format, but what exactly?

What resolved this issue for me was selecting the “Browser” destination on the low right corner:

Previously I had Nest mini selected and got the “incompatible items” message.

Although I see that the author of this post already has “browser” selected…

5 Likes

Hm - like dankrill I have Dahua and Amcrest cameras added to HA as/with Dahua, amcrest, onvif and generic camera and I try to play the stream to a Sony TV with build-in chromecast.
HA_Cast

If I open Camera I get

5 cameras are found but they are incompatible and I don’t have “Browser” in the low right corner. :frowning:
Home Assistant Core 2022.6.7

I assume this is because I don’t use/have cloud access or DuckDNS …

Edit: I think I’ve found the menu item you mean. :slightly_smiling_face:

There you can only select the device on which the stream will be played. But without a camera stream (cameras are incompatible) there is nothing to play.

Any RTSP camera you can play in the main screen is playable there too. My Nest RTSP cameras show up there.

OK now it’s working: Problem: Play camera stream with media player to an DLNA device :slightly_smiling_face:

Can you share what you did to fix the issue? I am having the same issue/problem

Not really. :slight_smile: Now I use Onvif and H.264 and it works.

It should, but no. My cameras run great in the dashboard with rtsptoweb (less than .5secs delay) But, they are not recognized on media section. On the other hand, im able to cast my dashboard so i watch the whole thing on the tv. But this generates imput lag so i have like 5secs stream delay when i do so :frowning:

Has anyone found a solution to this issue? I have a reolink camera I am trying to setup in home assistant. Set it up with the reolink camera integration, onvif, and also generic camera. When I go to Media->Camera and try to cast to any of my chromecast devices (or any device for that matter) I always see “3 incompatible items hidden”. The cameras work fine everywhere else in home assistant including on my dashboard.

The cameras also show up as incompatible if I try to use them as media within an automation.

Same here (again). Core 2023.4.x was ok. Now after the update to Core 2023.5.3 all my ONVIF Cameras are “incompatible” again.

ONVIF

Also see my other post: Problem: Play camera stream with media player to an DLNA device - #6 by jim_os

I haven’t changed anything in the camera settings. Stream is H.264. Rebooting the host (see my other post) doesn’t help either. The cameras are still and permanently displayed as incompatible.

I found my problem now. The RTSPtoWeb - WebRTC Add-on is the problem. When I disable the addon everything is ok and all cameras are available again.

HA Core 2023.6.1

Has there been a fix to this? I use.the RTSPtoWeb to help with latency. So I don’t want to disable it.

I have to revive this thread… While I do see the videos, none of them play.

As you can see, the files seem to be there; it shows date, time, length, and even what has been detected… I try playing the video in the browser, as has been suggested previously.

This happens on both Firefox and Chromium on my desktop PC as well as on the Home Assistant Android App. Videos stay at 0:00, they won’t load. I thought, perhaps loading these from the camera might be a bit slow, so I waited for like, forever. No difference.

I’ll eventually get this

While I do use Frigate, I completely shut it down while testing this - no difference.

I tested two other reolink cameras that have never been added to frigate - no difference.

I deactivated the additional ONVIF integration just to see if it’d make a difference - it didn’t.

When I try loading the same clips via the Reolink Android App, they clips will play instantly - there is not even a slight delay.

Anybody got an idea what to change in order to make this work?

1 Like

Years later still nothing?