Media folder location?!

Tags: #<Tag:0x00007f3270f6fed8>

I can’t seem for the love of god seem to figure out where the “new” media folder is located.
I’m running HassOS.
My testing tells me it’s not;

  • At the “actual” root; /media - this folder already has “cdrom”, “usb”, and “floppy”
  • At the /root; this is where I see addons, backup, config, share, and ssl.
  • At the /root/config; there’s no folder in here called media.
  • At /home/hassio - that folder is just empty.

The information here must be wrong - if that suggests the first point in my case.
I tried creating a new subdirectory and setting a media_dirs: to that folder but then I get this error;

not a directory for dictionary value @ data['media_dirs']['media']

Why can’t the media tab just show where it is located? Why do we have to guess?

1 Like

I had the same problem in my Home Assistant installation. To fix this, I created a directory titled “media” in my config folder.

For the configuration I used

homeassistant:
  media_dirs:
    media: /config/media

For some reason the media directory in the root folder would not work whatsoever so I had to declare it myself.

3 Likes

I think it’s just on HassOS that it was assumed it would work flawlessly for all, so there is no real mention of location.

homeassistant:
  media_dirs:
    media: /config/media

Thanks, man! This should be in the official documentation!

1 Like

I can confirm this was the only way I was able to get this to work and I spent hours trying multiple configuration options. The only way it worked was when I decided to user a different folder as suggested by @jaxonstagecrew and add media_dirs to my config.yaml. I tried just using a different folder without editing my config.yaml and it did not work.

It is. In two different locations.

So what is the conclusion? For hassos we have to use the /config/media folder for this? If I want to use /mnt/media, it won’t work?

None of those mention /config/media

It seems the documentation is not up to date or is incorrect.
It shows that an external directory like /mnt/recordings can be specified but that’s incorrect. You can only specify directories within the directories that are mapped on the docker process as volumes. I see the following volumes mapped on my homeassistant docker process

[email protected]:/mnt$ docker inspect -f '{{ .Mounts }}' homeassistant
[{bind  /etc/machine-id /etc/machine-id  ro false rprivate} {bind  /usr/share/hassio/tmp/homeassistant_pulse /etc/pulse/client.conf  ro false rprivate} {bind  /usr/share/hassio/audio/asound /etc/asound.conf  ro false rprivate} {bind  /run/dbus /run/dbus  ro false rprivate} {bind  /usr/share/hassio/homeassistant /config  rw true rprivate} {bind  /usr/share/hassio/ssl /ssl  ro false rprivate} {bind  /usr/share/hassio/share /share  rw true rprivate} {bind  /usr/share/hassio/media /media  rw true rprivate} {bind  /usr/share/hassio/audio/external /run/audio  ro false rprivate}]
[email protected]:/mnt$

If I am incorrect in saying this , please correct me.