Media Player Volume stopped working

Hi Guys,

I have a simple flow in my study where an Aqura cube controls my Sonos player. This has worked a treat for some time but after the latest updates I can’t control the volume. I get the following error:

Call-service error. ‘<’ not supported between instances of ‘NoneType’ and ‘int’

I tested this by just calling vol up through an inject node and get the same error


All other functions still works fine, just volume stopped:

Has anyone got any ideas?


Try removing the device. Only define the entity.

Hi @Mikefila

Thanks for taking the time to answer this. My original had no device and uses a variable for the entity. This all worked just fine for a long time, just stopped after the latest updates. I tried experimenting with the inject node to give it specific entities etc but no luck.

Last night I found some odd behaviour in Node Red where I copied a working node (Alexa Announce) and changed the text but no settings and it gave an error. I could export the node, change the text and import it and that would work, but not by just copying the node in node red. I could create an identical node from scratch and it would work. So in the example the node would work perfectly, but if I change the word ‘Test’ to anything else it would fail. This makes no sense to me. I’ve used Node Red to copy and adjust nodes hundreds of times in the past.

This leads me think there’s been some changes in Node Red which are a bit clunky. I will recreate the original volume nodes from scratch and see if that somehow fixes things. Part of why I love node red is being able to just copy a few nodes and re-cycle, saving time, not sure why this is now an issue. I’ll export two nodes that’s been copied and take a look at what the differences are in the full code.

Here’s the original for the volume, I think it might be to do with this same issue of copied nodes.