MediaPlayer-TTS how set up?

A bit frustrated noob here, as I seem to not be able to find a “How-To” to set up what seems would be a simple and very common situation. The documentation on Media Player has not helped me figure this out…

I want to be able to create automations that result in speech being sent to ESPHome speakers in my house – but clearly I am missing something…

I have a RaspiAudio Muse Luxe speaker set up as a voice assistant, and two M5Stack Atom Echos, and they have been working great for about 6 months now. It speaks back to me when I ask it to turn on a light, so I know both my voice assistant set-up and the speaker wotk fine.

I tried to set-up an automation to speak, via TTS to my MuseLuxe following the same steps in Kiril’s YouTube video

and my MuseLuxe did appear as an option for a media.player (the Atom Echo’s do not show as media.players). However, when I ran the “action” I got this

but when I tried to pick an “area”, “device”, “entiry”, etc, none “are available”, so there is nothing I can pick. This is what my automation action looks like

I am trying to get the notice that the alarm was armed to my speakers.

I’d sure appreciate any help or ideas, as I have not been able to find a solution. Perhaps too, a “How_To” document page woudl be useful to have… I know it is a very basic thing for most…

you need to add a tts provider.

perhaps try piper. instructions here:

I have, as mentioned I have all the Wyoming protocol bits needed to make voice assisst work – Piper, Whisper and openwakeword, and voice assistance has been working great for 6 months now…

Do I need to install anything other adons ? or HACS plugins ? Any settings I have missed ?

hmmm… maybe i’m misunderstanding the question. i thought the question is really centered around why the “+ choose entity” gives you nothing. is that the core question you have? without a tts.* entity, that tts.speak call isn’t gonna work…

apologies if i’m misunderstanding your question… if my understanding of your question is correct then…

for me i have tts.piper. and i got it from doing the install as posted on that page.

you said you have everything already installed… please verify you have this on your integrations page:

and when you click on that ‘1 entity’ you see this:

wondering if I also need to have the VLC add-on to make media.players work ?

huh… ok, then i’m at a loss too. i just tested on mine and this yaml worked for me:

service: tts.speak
  entity_id: tts.piper
  cache: true
  media_player_entity_id: media_player.study_sonos_move
  message: hello this is a test

to answer your vlc question, i do not have vlc on my system.

Choosing the media_player entity what do you see when press browse?

Thank you for the suggestions !

However I think it must be something simpel I am missing ? I am just trygin to duplicate what Kiril did ni the video mentioned above, which seems super simple…?

I have not had to add anything to my configuration.yaml, and I have Shelly, Homekit, ESPHome, HACS, and voice assist all working fine…

@mcarty …when I press that the only option is the muse luxe… whicih is what I chose… interestingly the Atom Echo’s do not show up, but they work fine with my voice assist

…maybe I need to back up a bit. After the muse gets installed into ESPHome, I added the “controls” to the dashboard, as done by Kiril,

Then I go to the dashboard, and open the “media” tab at the bottom right…

then chose “test-to-speech”

and then chose either “piper” or “homeassistant cloud” and press say

but nothing happens, no sound comes out of the muse luxe… it is like the muse is no tbeing connected to… the logbook on the muse shows nothing of an attempt to connect to it… so it seems I am missing something in the middle ?

In order to have TTS work propertly looks like I neded a different YAML config file. I was using the YAML file provided by RaspiAudio in their website, the makers of the Muse Luxe. However Kiril in the YouTube video Iquoted above, is using a different YAML file for the Muse Luxe, one provided in the EXPHome website. Links below.
There are some differences in the files, but am not an expert, so not sure what they do.



arghhhh !..
…but now, the wake-word entity for it, while listed as an entity, is unavailable !..

the Muse Luxe has been around for 2-years ? already, lots of YT videos on it, but a working config seems is still not available ?.. sorry, ranting, but a bit underwhelmed by it all… the unit costs 59 USD…