Mediola2mqtt: Simple Mediola to MQTT bridge with HA support

Tags: #<Tag:0x00007fc411acf670>

The Mediola Gateway is a multi-protocol, mult-transceiver networked gateway available as Mediola AIO Gateway or OEM product. It is the only gateway that supports my blinds (Elero) and it is widely available in my region (the Elero Centero home gateway is a rebranded Mediola gateway; there is an alternative for Elero blinds based on the Centero transmitter stick, but the Mediola gateway is cheaper).

The gateway has an HTTP API and reports important changes via UDP broadcasts. I created a simple MQTT gateway with HA auto discovery to make use of the Mediola features.

Limitations:

  • Only limited device support
    • Elero blinds
    • Somfy blinds
    • Intertechno remotes
  • Tested and developed on a v4 and a v4+ device

There is now rudimentary support for v5 and v6 gateways. For the v6, you need to map the UDP port 1901 to 1902 since it broadcasts on a different port.

When running standalone, also several Mediola gateways are supported.

See GitHub - andyboeh/mediola2mqtt: Mediola MQTT Gateway for instructions and details.

1 Like

Thanks for your contribution.
I tried your code on my new V6 today. It work flawless with elero blinds.

Thanks for the feedback, good to know that it works on newer models as well!

Today, I played a bit with code, and moved configuration from file to configuration tab inside addon

:smiley:

Any contributions are welcome, so I’d appreciate a pull request. However, as I cannot run it as an addon, I will only accept changes that do not break running it as a systemd service (that’s the reason for the external configuration file, but with a few adaptions, both should be possible).

Can I use this to open and close my elero blinds?

That’s what it was written for - provided that you have a Mediola Gateway.

I think I need help with the settings.

mediola:
  host: is this the mediola gateway? can I use the IP?
  udp_port: 1902
  password: is there a password?
mqtt:
  host: the homeassistant ip?
  port: 1803
  username: homeassistant
  password: somepassword
  discovery_prefix: homeassistant
  topic: mediola
  debug: false
blinds:
  - type: ER
    adr: '1'
    name: Kueche
buttons: []

Maybe you can help? :slight_smile:

  host: is this the mediola gateway? can I use the IP?

Yes, the gateway. Of course you can use the IP.

  password: is there a password?

If you didn’t set one, there is none. That’s the password of your Mediola.

  host: the homeassistant ip?

Depends on your setup, could be the same IP address. You need to find out how you can reach the MQTT server.

Hey @andyboeh,

Thanks for all your work on making this really simple and easy!
What i noticed is, when autodiscovery does not work and i manually entered all my elero blinds from a Gateway 6, that the addresses are now in hex, which means after 08 it goes on with 0A. This seems not to be supported yet as you parse them as int always.
For myself, i removed that part in the script and use directly the adr field and it works flawless.
Maybe this is worth a consideration in the future to also fully support gateway 6.

It only affects people with more than 8 elero blinds on a gateway 6

No, the addresses are in hex on the v4 gateway as well. I stumbled upon this when I added my tenth blind a few weeks ago and it should be fixed since then (there are internal conversions hex <-> int).

Could you check if you run the latest version?

Regarding the v6, there is an ongoing discussion to better support this gateway. If you like, you can join the conversation at Behaviour of v6 gateway · Issue #4 · andyboeh/mediola2mqtt · GitHub.

Hi!
Thanks for your fast reply.
Yes, i will join the discussion.

I took the state of the master branch 3 days ago. Can you tell me, which commit you used to fix it or if it is merged there?

Hi Andy,

Thanks for this initiative

Do you know if it also works on the rebranded “Centero Home Gateway”.

Rob

Ja

Sorry, I don’t know - if you try it please let us know your results.