MerossLAN Devices Constantly Going Unavailable

It seems as though with every new HA update my Meross devices are becoming more and more unreliable. They are constantly going offline. I have these devices completely disconnected from the Meross Cloud with no cloud configuration whatsoever. Sometime a reload of the device integration brings it back and sometimes many devices are all offline and I have no choice but to completely restart HA.

Anyone else having these problems? I’m about ready to start planning to cull all of my Meross WiFi devices and switch to ZigBee devices.

Why not go through

Easy to implement

@ClassicRed didn’t you see from the title that is the integration I’m already using?

So am I correct in thinking that either there are not many people using Meross devices with HA or, if you are, you are leaving them connected to Meross Cloud?

Yes, I have the same issue always losing connection HA integration. It’s very frustrating as you can’t rely on them. I might have to ditch the meross switches.

I am having the same problem. Having to restart HA at least once per day to restore connectivity.

Connection to Meross Cloud works just fine.

I have tried all 3 options for the Meross config in HA to no avail.

I’ve lost all connection to Meross Cloud from HA. Direct connection to Meross works fine. Backup restores are not fixing it. I guess this is motivation to figure out the LAN method.

I’m also having issues with a couple light strips constantly going online/offline. The problem with Meross Cloud integration is the color temperature setting doesn’t work at all. I’m really stuck bc not all of my meross devices are doing this, just a few.

So came across this thread a few months back when I started having issues with Meross.

All started well then it says unavailable all the time, however every minute I would get a very quick blimp of the numbers, could not switch on/off etc. Furious like the OP said I was about ready to ditch it all and go with something else, even bought a ConBee stick.

However today, I needed the phone app to check some figures. There was an firmware update to do, low and behold, did the firmware upgrade and now its all running again.

Looks like they keep changing the way API is structured with nearly every FW update.

Hope this helps someone out there.

Big problem I have is that my devices aren’t connected to Meross anymore. I wonder if there is another way to get the firmware updates.

Experiencing the same issue and found this thread

Have you tried the non-local integration?

Im having this issue now. I have them connected to Meross and have updated the FW, but it still happens.
4 controllers, all intermittently offline in HA using the LAN integration but online in HA using the cloud integration.

Do your Meross devices support HomeKit? I use the HomeKit Device integration in HA with Meross and do not experience any problems with the devices becoming unavailable.

1 Like

I only have my devices connected to HA via local MQTT, no cloud. I have a only a few that are HomeKit compatible and since migrating to a new Raspberry Pi 4, from a 3, where I had to repair all of my Meross devices I haven’t noticed as many disconnects. One other key aspect that I think was at play for me is that originally I had been using the blank device key method(hack) and I think this attributed to more unreliable devices. Since I have properly configured my devices with a key and confirmed proper username/password setup for my devices with my local MQTT things seem pretty solid.

I also have a meross_lan device that won’t stay available:

@BrownhillCreek how do you have it configured, and what model and firmware is the device? I took a look through a number of my devices, a few different models, and I’m not seeing any of them become unavailable.

I was having trouble with a MSL430 night light specifically. I just remembered it supports HomeKit so I’ve paired to Hass via the HomeKit Device integration and will see how that goes.

I have some other mss310 wall plugs and they have been solid all along.

@BrownhillCreek I guess my real question is do you have that night light fully local only? Do you still have it connected to Meross Cloud? Also, did you pair it using a device key or use the blank key hack? I have found that when I was using the blank key hack the it wouldn’t stay reliably connected.