Messed up maps

Today when I went into maps (homeassistant.local:8123/map) there was no longer the option to add a zone or edit existing zones, there was only the edit pencil in the top right hand corner that gave me the option to “take control of your dashboard”. I tried this and it went blank. I then deleted the default map dashboard and tried to create another which is now at homeassistant.local:8123/dashboard-map. It has my old zones but still no add zone function and I cannot edit any zone.

  1. How do I get back the default map at homeassistant.local:8123/map (now empty error 404)?
  2. How do get the “add zone” and edit functions back?

Manage dashboards, delete your new one if you don’t want a separate dashboard. You can create a map view on your default dashboard with view type of Panel, and add a Map card.

Zones are defined under Settings / Areas, Labels and Zones.

You can add zones in the settings.
In the new map dashboards you can configure which entities (zones, persons, devices) you want to show, which was not possible in the default map.
To do that edit the map using “Edit dashboard” and confirm taking over the control.
Then you get a editable dashboard with only the map card.
Click “edit” on that card and now you can add / remove entities

1 Like