MetOffice Sensor using incorrect location

I’m trying to setup the MetOffice Weather sensor and I’m getting an incorrect location, I’m using the following:

  - platform: metoffice
    api_key: !secret metoffice_api_key
      - weather
      - temperature
      - feels_like_temperature
      - wind_speed
      - wind_direction
      - wind_gust
      - visibility
      - visibility_distance
      - uv
      - precipitation
      - humidity

And instead of the weather for my location it’s using the Valentia Observatory in Ireland. According to the documentation is should be using the location I have specified in configuration.yaml. I added the following to the sensor configuration:

    latitude: !secret latitude
    longitude: !secret longitude

but that again doesn’t have the correct location and gives me the weather details for Ireland.

I also tried the MetOffice weather platform, instead of the sensor, and that results in the same behaviour, i.e. the Valentia Observatory in Ireland instead of my actual location.

Does anyone know what’s going on here and have ideas why I’m getting information for the incorrect location?

Have you got the correct settings for long and lat of your home?

    latitude: !secret latitude
    longitude: !secret longitude

are locations held in the secrets.yaml and if they don’t exist there it will never be accurate.

Only you know these as you know your home address. Use google maps to find your home and copy them to the secrets.yaml file in the following format

latitude: (your grid lat)
longitude: (your grid lon)

check your config and restart.

The locations are correct, got them from Google Maps and other sensors/components that use location get the correct location.

Interesting - I don’t have any location data other than my home but my Met Office uses a site just 3 miles up the road from me.
I’ll just login to the Met and see how I configured it!

Go back to the met office api page and check your settings there.

Not sure what you mean? On the MyAccount page for the MetOffice, where my API key is listed there are only settings for my name and job details. There don’t seem to be any settings related to the DataPoint API?

Stumped on this will have to step back for a more experienced individual. Sorry but I tried anyway.