Miflora not connecting


I got a new Mi Flora plant monitor, but I am having issues connecting it (running hassio). I have another one that works just fine.

Here is the config:

  • platform: miflora
    name: Fern
    mac: ‘c4:7c:8d:6a:09:2b’
    • moisture

This is what the log says:
2019-01-29 09:23:41 DEBUG (SyncWorker_12) [homeassistant.components.sensor.miflora] Polling data for Fern Moisture
2019-01-29 10:23:51 INFO (SyncWorker_1) [homeassistant.components.sensor.miflora] Polling error Could not read data from Mi Flora sensor c4:7c:8d:6a:09:2b

I confirmed with Bluetooth LE Explorer that the mac address is correct.

I can connect and read the data using both the Mi Home app and the Flower Care app. I installed the most up to date firmware and the issue persists.

Can anyone think of why it doesn’t work?

does the hassio device have bluetooth?

(I know - basic question - but does it? did you run bluetooth le explorer on the same device as hassio?)

Yes - other Bluetooth LE devices work without issue. I think my devices are the chinese version instead of the international version. I assumed that since they worked in the app they would work with the miflora component, but maybe I am wrong.

The Chinese version should work too. Have you tried moving them closer to each other (<2m)?

Hi hongtat, do you have a working Chinese version? As the component docs state there maybe an issue using the Chinese ones. I only ask as I am about to purchase one

I got it from Taobao.com store - it should be Chinese version.

My issue resolved itself - not sure why, but it works now (with Chinese sensors).

Thanks for both confirming, will order a couple today. Chinese seemed to be a lot cheaper so will go with those!

So no idea how it was resolved?

I ran an update to 88.2 last night and one of my sensors is now not showing values (all four i have are international):

019-03-02 08:59:18 INFO (SyncWorker_11) [homeassistant.components.sensor.miflora] Polling error Could not read data from Mi Flora sensor C4:7C:8D:66:E0:A3

Any suggestions? I’ve tried reloading host, changing battery of the sensor, trust/pairing in bluetoothctl (the device gets discovered), etc. Nothing seems to have fixed it so far…

As the distance is not sufficient on my case, is it possible to use a USB dongle (if yes which one is suggested) ?

Currently using hass.io with raspberry Pi3 B+, is it possible to use a BT dongle? (shall I disable the internal?)

depending on your distance requirements, consider a RPI zero (with wifi) and run plantgateway on it. More complex set up, but it means you can keep your hass install where it is and run one or more gateways elsewhere.

there are details under components somewhere.

Hi Good suggestion.

I tried but I had an issue with the script:

Connection Refused error

Others had the same and I did not find a solution…

I took a different approach, installed hassio on raspberryPiZero W and make it reporting to my central db on influx DB.

It would be a good idea to enhance and get the info of the RSSI or equivalent info from the last read out.
It may be really help to see what is critical for the BT communication (cover closed, behind an object… and to find the optimal place for the device with hassio)

Hi, I have similar issues using the embedded BT in an 8th Gen Intel NUC i3. the sensors are in another room in the house, but there is a [not very satisfactory] work-round. If you software restart HASSIO with the plants close to the NUC then all is ok, you can then move them away and things carry on working, but the moment you restart HASSIO you will loose connectivity unless you move the plants back close to the NUC.

It looks like what is required is some kind of restart script for the BT part of Home Assistant Any suggestions would be appreciated, Wi-Fi is switched off on the NUC so local interference should not be the issue.

For reference my configuration looks like this:

  - platform: miflora
    mac: 'C4:7C:8D:6A:50:48'
    name: Basil
    force_update: true
    median: 2
      - moisture
      - light
      - temperature
      - conductivity
      - battery
  - platform: miflora
    mac: 'C4:7C:8D:6A:63:19'
    name: Chives
    force_update: true
    median: 2
      - moisture
      - light
      - temperature
      - conductivity
      - battery

Hi! Don’t know if this is to any help, but my sensors won’t work (can’t connect) if the soil is to dry. Try to water a bit where the sensor is?

We also had a problem that after restarting HA could not connect. When we released the console command:
hcitool lescan
again HA joined me flora and shows the data