Migrate HA to new system

“HA” as in, ‘Ha ha, good luck!’

Where?

Are you sure?

You need to put the copy of your backup in the backup folder first for it to show up there.

Potentially helpful would be an option, anywhere, to restore from a backup.

The verbs I associate directly with backups are take, make, backup, and restore. I don’t believe I’ve seen any other UI refer to the act of restoring something from a backup as the uploading of a file that contains the result of the earlier backup action.

I suspect that if I had come across the upload action in Home Assistant’s UI prior to reading this thread, I would have assumed that it meant the uploading of a backup from Home Assistant to some remote artifact storage system, not the uploading from my web browser to Home Assistant with the implication that Home Assistant would then, without further action on my part, use the uploaded backup to perform a restore action.

In a clean install, Settings → System → Backups does not exist. There is no restore option.

What backup folder? It’s in a backup folder, sure, that got created on my config folder on the installation I’m migrating from. But where are the new config and backup folders on a fresh installation? They don’t seem to exist and as I’m migrating to a completely different setup (python venv on macos from debian docker) so the paths are totally different.

I’m going to wipe and start over from scratch for the third time today just to be sure, but the last two times, I didn’t see this.

EDIT: Confirmed. I just went through the onboarding again. There is no option to upload a backup. Nor is it mentioned in the onboarding docs: Onboarding Home Assistant - Home Assistant

It appears HA backups are a one-way street: backup, but not restore. I guess we could print out the files and fold them into party hats, or something.

EDIT: Overall, this is a complete mess and could use documentation. Has anyone ever successfully accomplished this? I did figure out that if I copy the contents of my debian server’s “/drive/home/user/config/” folder to my Mac’s ~/.homeassistant folder, it will start up without error, but my dashboard is very different, none of my customizations are there anymore, and although it does list many of my lights and scenes, almost none of the controls work.

My System → Backups does appear now, providing no button or any other apparent way to restore from the backup. Once again, perhaps printing the backup file out and folding paper airplanes out of it will at least give HA’s “backup” feature some practical value.

Also my settings screen now shows errors that don’t appear on my Debian install’s settings screen, and seem to have been written by someone not entirely fluent in English. “Move your YAML configuration to integration key”? It almost makes sense… almost…! Screen Shot 2023-11-03 at 4.07.16 PM

Also, apparently they’ve integrated an chat “assistant” now, which works as well as every other “chat assistant” in terms of telling you it doesn’t understand simple questions… sure wish they’d have gotten their documentation finished, so we could know how to do simple essentials like migrating to another server, before spending man-hours implementing “gee whiz” features that don’t actually work…

All in all, a terrific nonworking and undocumented mess, as near as I can tell. Guess I’m stuck still wasting an ethernet port on my router to remain joined at the hip for the forseeable future to this ancient Dell Mini 9 that I really wanted to put out to pasture. Seems awful silly to force users to keep using their most obsolete hardware, though, by not providing any way to migrate off it.

Ugh. A Dell Mini 9. I am reliant on using a Dell Mini 9 in daily service. I can barely face myself in the mirror.

In all seriousness, I’m starting to get disk errors on the Mini 9 and need to retire it soon, and this has already consumed way more time than I have available. I’m not rebuilding my entire setup by hand from scratch, that’s not going to happen in this lifetime. It’s not worth it. This stuff needs to work if it wants to see adoption. Maybe it’s time to give up on the fantastic dream that there might be an open source package that can control my wifi lights and actually works, and just give in and pay our masters at Google or Apple a fortune to let them plant spyware in my home that I pay them 10x their manufacturing costs for. This is, seriously, not working for me. I’m getting tired of wasting time like this. It’s been two days now trying to make this happen and that’s just too difficult.

2 Likes

There should be a “Restore From Backup” option right on the initial Welcome screen. Did you get that screen, and try that option?

F’in hell. What UX genius made that design decision? Three times I didn’t even notice that, I’ll give it a shot. Thanks.

Wait. Nope. How are you getting that option? It turns out I’m not completely braindead, I was right the first three times… I don’t have that restore option on mine. How did you turn that on?

Hold it. According to Restore from Backup on New Installation - HA Core - #3 by CentralCommand

If you are looking for a backup and restore process for a core-only installation or to migrate between two core-only installations then you must set one up yourself.

So there is literally no way to migrate a core installation (I have no idea how to “set one up myself”, since directly copying the files doesn’t work, and I got into this to use HA but not to wind up coding it.) I thought I was joking about the “backup” feature being one-way, backup-only, without the ability to ever restore, but according to this guy, who is the only person I’ve found online who actually seems to understand this process, that’s the actual literal truth of it. There is no restore feature.

This is some of the worst design I’ve ever seen. My faith that HA is worth spending time on just bottomed out. It broke through the bottom, and hit a whole new bottom underneath that I didn’t even know existed.

So, once my Mini 9 finally bites the dust, that’ll be the end of Home Assistant for me. People need to be able to migrate their settings to another machine, not be stuck forever on whatever machine they first built their starter system on. Anything else is not practical for real-world use.

Especially as, I don’t mind having to put work in myself on setting up a FOSS project, but the fact that it took me an entire afternoon out of my day to even discover that this problem exists, shows that this is too chaotic and poorly designed an ecosystem to rely on. Every aspect of this seems to be mired in confusion and incomprehensibility.

This is really just extremely, extremely disappointing.

Thinking out loud… maybe I can just clone the current hard drive to an image and spin up a debian machine in vitrualbox and without having to change anything. Still, I don’t think I want to bog my mac server machine down running virtualbox 24/7, that seems inefficient.

It seems like the only practical answer is to enjoy it until my Mini 9 finally crosses the Rainbow 802.1D Bridge and then go back to using electric light switches.

Core installations are aimed at very advanced users, and Core clearly doesn’t support managed restores - it’s up to you. Only about 3% of the installed base is using Core, and for them, a totally manual backup/restore process is a feature not a bug. Is there a particular reason you are using Core? Use and support of this system is so much simpler using HA OS.

1 Like

I looked for install instructions for Mac, followed them, and core is what I wound up with (two different sets of instructions, actually, and they were similar enough that I figured they were the way to go.)

I did try HA OS once, a long time ago, and yes, “simpler” would be one word for it, sure :slight_smile: . Aside from the fact that I’m not going to take the performance hit of perpetually running virtualbox on this machine, HA OS seemed so locked-down and limited, there was no way to do the very things I had wanted HA for… like, the very first night I hit so many brick walls, I uninstalled it and never looked back. It just wasn’t even usable. If HA OS on a Mac had worked for me, I never would have wiped my Mini 9 Hackintosh to install Debian & HA to begin with.

Against my better judgement, since my last post, I did try another complete system reinstall to clear everything out, and installed the versions of Python and Home Assistant that are working on the Debian machine, then installed again and copied all the config files over, just to see. Still no dice.

I think HACS may be involved… don’t even get me started. If HA seems blissfully ignorant of the need of users to occasionally migrate to a new server without having a Home Assistant Engineering PhD, HACS seems downright hostile to it. There’s simply no way (that I can find in several hours of searching, at least) to install it at all if you’re trying to migrate a previous version of HA, as is, without introducing breaking changes. It forces you to first upgrade everything to more recent version than the last one I know works, with no previous version that might be compatible with HA versions more than about 5 months old available anywhere I can find.

I’m not going to troubleshoot a forced upgrade to a version that is not confirmed working with my current setup, so this whole endeavor has now come to an unproductive end exactly where it started two days ago: with me running HA on a dying Mini 9 and looking balefully at a perfectly good extra Mac sitting here without my HA install on it.

I’m not clear why the options are so limited. I can’t be the sole person who hoped to use HA who is neither a complete newbie who requires a totally locked-down and inflexible software appliance, nor, an expert HA developer who wants to spend his time coding the features he needs completely from scratch himself.

No SW engineer or business would be crazy to implement rare use cases like what you are suggesting.

Simply put, if you do not have the skill stick to HAOS, otherwise you are on your own with a bit of help from the HA community, but nothing more than that.

Nobody has the time or the money to cater to marginal use cases. HAOS is SW for smart home automation, not a general purpose OS, plus you can do more with HA comparing to any other similar platform. Alternatively you could consider Node-RED.

You want freedom? Use a hypervisor or supervised installation, not a core installation.

The speed difference between HA deployment methods is marginal. It is more important you do not use a compute potato to deploy HA.

1 Like

Sorry, but, it sounds like you didn’t maybe read my comments. “crazy”? “rare use cases”? “general use os”? What? At first I thought you were replying to someone else, it sounds like you read a lot into my comments that isn’t there.

I don’t understand what is “rare” or “marginal” about wanting to take my working installation and move it to from one Unix OS to another newer and more powerful machine on a Unix OS*. In my 25 years as an IT consultant, I’ve definitely run across that need a few times. (*you do know MacOS is just a proprietary GUI running over a certified Unix flavor, right?) Or about turning to FOSS because I want something flexible, but which doesn’t require me fully coding important features completely from scratch.

Is being able to restore my settings from a backup, or otherwise migrate them between installations, really that outlandish an idea to you? You know an overwhelming majority software packages that have more than a very small handful of configuration settings have ways of backing up and restoring them, right? And that usually, when you make a backup, it’s for something other than just taking up space on your disk? None of this is something that any software engineer would balk at implementing.

I do understand that Macs are a very small share of the market, but nonetheless I don’t think supporting them is “crazy”, especially as I install plenty of other Unix software ports and other than HA it all runs on Mac’s Unix underpinnings with few troublesome issues, and pretty much no unsurmountable ones. From what I’ve seen, plenty of my fellow SW engineers have the time or money to make software that works according to very common conventions and general common sense about usability, and to document it. Even FOSS software. Even stuff that is ported to Macs. It’s really not crazy at all, or some sort of rare edge case.

I don’t know whether you’re calling me a “potato” (you know what, I actually listed my career credentials here at first, but decided I don’t need to get that pompous), in which case your opinion is, uh, noted, or calling Macs a “potato”, in which case, all I can say is, so far everything else I’ve needed in the last couple of decades runs on them, including using them as servers of all different stripes, so they must be somewhat more computationally powerful than a tuber.

Last week, on a Mac with lower specs than the one you’re calling a “potato”, I set up a full Apache/MySql/PHP8/Wordpress stack with several domains running as virtual hosts, and that machine also runs a dedicated database server for my own software that does automated imports and data-heavy trade processing from my stock broker via API every day, and, also, clunky ThinkOrSwim desktop software that I use manually for a couple of hours on it every weekday by screensharing in via one of the three different remote desktop protocols I’ve got running on it (I can’t afford not to be able to remote in, so I need redundancy.) That’s all running at the same time, with no problems at all. So, calling a higher-spec machine than that a “compute potato” is, in my view, perhaps misinformed.

Meanwhile, for several years I’ve had HA running successfully on a 2008 Dell Mini 9 with a teeny little Dell low-power Atom CPU, 1GB ram, and a 32GB SSD hooked up via USB, pretty much a glorified pocket calculator. Given that experience, I have a hard time understanding why someone would claim a 2.5 GHz dual-core i5 Macbook Pro with 16GB RAM and 1TB internal SSD is too much of a “potato” to run just HA and its dependencies, all alone, with nothing else installed besides the stock OS. Something about that just doesn’t sit right, somehow.

If you ask me, the Mini 9 actually, literally, has not much more computing power than an actual potato that you’d cut open and melt butter and cheese into. Yet I’ve had HA controlling my smart bulbs on that for a few years, so maybe tuberosity isn’t reeeeeeally a problem for running HA?

And, as to not wanting to roll to a new version and a new server at the same time, that’s not unusual either. Anyone who’s ever done a lick of troubleshooting knows that you isolate your variables. You don’t migrate AND upgrade in one fell swoop, you do first one, make sure it’s all good, then the other. That’s not “crazy”, that called “having had way too much experience with IT”. And if you google for it, you’ll also see it’s not only not “rare” but incredibly common for people to need older versions of software packages, too. Sorry, but it’s just not something most people consider unserviceably out-of-the-ordinary.

And even by those standards, me running a 9-month-old release instead of this month’s version is just not that extreme a case. The “old version” I’ve been talking about, that in HA world is being treated like it’s so archaic it’s unthinkable anybody could ever have a reason to still be using it, is 2023.1.7. Call me crazy but I don’t think 10 months of backwards compatibility is really so outlandish a request.

None of this is as weird as you’re trying to claim. Maybe in HA-world, but not anywhere else.

As to the other versions: I followed what instructions I could find. I’m open to instructions on how to get hypervisor or a supervised installation running on a Mac, if that will allow me to migrate my existing working install to a machine that’s likely to outlast as Mini 9 that’s almost as old as my last girlfriend. I’m just concerned that that ancient hardware isn’t going to run forever, and now I have a spare MacBook Pro sitting here which, until you just corrected me, I didn’t think it was that unheard-of to want to port my configuration over to. Although it does seem silly to me that there’s this one Unix app, the only one I’ve ever run across myself, that can’t run on the Mac’s Unix underpinnings, and demands virtualization. Unix multimedia production apps can be ported to Mac, you can get generative AI running on Macs, but a Python home automation app can’t control a couple of smart bulbs without setting up a whole virtual machine for it? Ok.

In fact, I wasn’t going to mention this because I didn’t want to bog this thread with what would have felt like it was getting too far off-topic, but, since you suggested exactly this:

In fact, after my last comment, before I saw your diatribe, I did head over to MacOS - Home Assistant to give another shot to HA OS running in VirtualBox, just to give a less “crazy” and potatoey method another fair shake, and see if the limitations still seem like showstoppers.

So, yes, I’ve now tried HA OS.

INB4: I followed the instructions to the letter. Once I had, I went back over them, sentence by sentence, double- and then triple- and quadruple-checked all the settings and instructions they give, to be completely sure I hadn’t misread or overlooked anything. I also confirmed that wifi is off and the machine is accessible over the network through the ethernet cable. I now have VirtualBox (a system I’m familiar with from work, by the way, I wasn’t going in cold) configured, verbatim from their instructions, using the vdi image they supplied.

So. Here’s HA OS on Mac, as provided by carefully following the official documentation:

Screen Shot 2023-11-03 at 11.31.13 PM

I’ll forgo a sarcastic comment here. I did think of a few good ones, though.

Still open to working instructions for any kind of solution if anyone has got them, but as far as calling me or my computer a vegetable, or telling me what I’m asking for is too “crazy” in your opinion, or anything else that doesn’t contribute to getting my working HA install migrated to my Mac, I’m going to try to resist the urge to reply to any more of it.

I’ll have a look at Node-RED, I’m not familiar with it. Thanks for the suggestion.

Run it in a KVM, unless you consider Oracle SW standards compliant.

My objective was not to hurt your feelings, rather to point out RTFM prior to deploying anything.

Honestly, running HA on a Mac for production use is a very rare usecase and totally understandable that the dev resources are not focused on this. Most of the issues or lacking feature support is documented. Since you seem to be experienced in the IT world, you should understand that there is a never 100% guarantee for application to work when moving from one platform to another. But hey, how about contributing your year long knowledge to make the whole solution better every day? Which part of the code has been provided by you?

I recommend stopping your ranting and buy yourself a boxed hardware solution. If it is homeassistant or anything else is up to you.

Hey guys! I suffered a lot with this too. I found the necessary options on the interface, but it always said that the file format was not suitable, even though I had saved it under the exact same version 2 minutes earlier, even the rPI4 was the same, only the card was different.
It turned out that doing this under Firefox worked with the Chrome browser. It’s completely incomprehensible because the upload goes smoothly under Firefox in other cases.