Restore from Backup on New Installation - HA Core

I installed Home Assistant Core on Armbian. I would like to use a backup from a different installation. The account creation screen does not have the restore from backup link on it. Any ideas on how I can do this?

Use throwaway credentials to get in, then run the restore as your first activity.

In my case I login with throwaway, install the Google Drive Addin, login to Google and run restore from there.

1 Like

You cannot restore backups in a Core installation. Only supervisor restores backups and core-only installations do not include supervisor. As it notes in the backup integration:

This backup file can be used if you migrate to Home Assistant Operating System.

That’s all it can be used for. If you are looking for a backup and restore process for a core-only installation or to migrate between two core-only installations then you must set one up yourself.


D’oh completely missed core only. Nice catch Central.

Hi, I am trying to migrate from Raspberry Pi 2GB (RPi2) with SD 32GB to Raspberry Pi 4GB (RPi4) with SD 64GB.
After the fresh installation and restoring from backup on RPi4, HA works fine, but can’t run Studio Code Server (VSCode) or Terminal… I have tried to reinstall VSCode and Terminal, but doesn’t help.
All other apps running without problem.
All add-ons looks, like I cannot make it to run.

When I plug in and turn on RPi2, VSCode, Terminal … all works fine.

Any suggestion on what may cause the problem?

ALL SORTED - I just needed a clear cache in the browser


For those who using docker version, you can easily restore from old server (I’ve tried even from older server version) to new fresh installation, just copy all of config dir from old server to new server (I’m not sure about file .HA_VERSION, but I keep that file with newer version, don’t replace from backup)

Just make sure you run docker with persistent volume for easy backup-restore

docker run -d --name=homeassistant \
  --restart unless-stopped \
  -v /data/app/homeassistant:/config \
  --network host \
  --privileged \
  -e TZ=Asia/Jakarta \

I’m using Google Drive Backup addon too, is necessary to install it as first acrivity? is the reason why I cannot restore from system? I know that the google backup addon use the same snapshot of home assistant. I’m running on a rpi3 and want just to switch to a best micro sd card.

No, the addon isn’t necessary. You just need to physically get the backup files onto the HA system in the /backups folder. The addon makes that easy if you’ve been using it. It can also be done manually.

Or if your backups are sufficiently small you can upload one during onboarding. There’s a size limit for that though, forget what it is

Thanks Mike. In my case, nothing seems to happen when I click on restore.
I load a backup file (upload) from my laptop on the HA system.
I select the item and leaving “full backup” checked i click on RESTORE.

I’m not very expert on HA so I don’t know where to find any log of what is happening at all.

Go to Settings → System → Logs (or click this button):
Open your Home Assistant instance and show your Home Assistant logs.

In the top right if the logs page there is a dropdown that says “Home Assistant Core”. Change that to “Supervisor”. There should be some information about what is happening. You should see a line about “starting restore” and then probably some error following that which can give some insight. Share that info here and maybe we can figure out what’s happening.

Side note - can you start a new topic with that info? This thread is about how to restore a backup on an HA core installation. The answer is quite simple for that - you can’t. Core type installations have no restore backup option.

If you’re using an addon then you aren’t on an HA core installation so this is a different topic now.

1 Like

Thanks again Mike, you are right: I’m very sad because I’m on HA Operating System (9.3).
Forgive me. I search again or will open a new topic.

1 Like

I’ve had issues last night where I’ve backed my work up and done a reboot as instructed to get an add on working.

It restored to a fresh install.
When I go to load the latest backup of the day it just goes back to the fresh install account setup.

Could this be because I’ve set up the fresh login not as supervisor?

I’ve lost about 6 hours worth of work now.

This doesn’t work anymore. I copied the config dir to my fresh install on another machine and HA is unusably broken. My dashboard is different, 99% of my lights and scenes do nothing, and my Settings screen is full of weird errors in badly broken English.

Make sure to copy all files (with cp -a /old_config_folder/. /new_config_folder). I had the same problem and after properly copying all files everything was exactly like it was before.

I found solution which is probably not intended. Decided to move my installation from SD card to USB SSD running in raspberry pi.

  1. Took full system backup and downloaded it to my PC
  2. Installed the newest version (11.4) of HASS into SSD using Raspberry Pi Imager
  3. Shutdown the Raspberry
  4. Removed SD card and added the SSD into RPi
  5. Started RPi and new installation started
  6. After while opened the basic address (homeassistant.local:8123) and the first initialization view was there, but no “Restore from backup” options anywhere… “oh f***”
  7. Came to this site to lookup for solution
  8. Started to type new throwaway credentials but then accidentally pushed back button in my mouse and TADA, the restore from backup option appeared!
  9. Now the restore is in progress, will report if that does not somehow work

edit: Everything went well, happy camper!

I have similar problem.
I’m trying to make a clone of current HA setup to be able to securely try some new things.
I’m running OS version on VirtualBox.
I created second VM from the same file haos_ova-11.3.vdi, then on first login page I restored from my last backup that was done last night on the first instance.

After restoring from that backup none of the add-ons is able to run. Also very simple ones like File Editor or Terminal and SSH.

I did clear my browser cache, but it did not help.

Any suggestions how to successfuly clone HA?

  • Piotr