Migrate MariaDB from old system to Home Assistant OS

Tags: #<Tag:0x00007f328a9480b8>

Hi guys! I was running supervised installation on an Ubuntu Server VM on my QNAP NAS. Because of recent updates in how Docker works the installation method is no longer working so I switched to an Intel NUC and Home Assistant OS. I have migrated the system using a snapshot but I am having trouble migrating the DB.

The problem is my DB is 2.7GB. I managed to reduce its size to 150MB but the phpmyadmin addon upload limit is 2MB. So far I have tried the following approaches:

  1. I tried increasing the phpmyadmin max file size by adding ENV variable to the docker container UPLOAD_LIMIT = 3000000000. (I have used this approach many times on the official phpmyadmin docker container and it works.)This crashes the container and returns this error:
[08:16:36] ERROR: Got unexpected response from the API: Service not enabled 
  1. On the MariaDB container I tried setting Manual network port publishing to expose port 3306 to the host IP so I can access the DB from Datagrip on my Mac. I managed to access the DB and upload the sql dump from my old DB but this also leads to a crash of phpmyadmin addon with the same error.

Can you suggest me another method that is proved to work. I want to retain my current DB because I have valuable data there for energy consumption.