Migrated automations not showing


I am currently running my config through “packages”. I set up sensors, automations, scripts etc all through the relevant file, eg config/packages/kitchen.yaml.

  customize: !include customization.yaml
  packages: !include_dir_named packages

It’s been working fine, but recently I have a warning saying the input datetime isn’t right - but I don’t know where that is as there are dozens of files!

So I thought I would start to migrate the automations & scripts over.

I migrated one automation over. It placed the automation in config/automations.yaml. However, I have my automation file within an includes folder. I set this in configuration.yaml as follows

automation: !include includes/automations.yaml

So the migration (and in fact any automation I create in the GUI) saves them in config/automations.yaml and not my specified path.

I removed the custom path, so it would look for the automations in the root config folder. However it’s still not seeing them?? They are definitely in the yaml file as I can see them. The UI just isn’t picking them up. I’ve tried forcing refresh, emptying cache and everything.

Any ideas??

I have removed the packages and all references to the includes folder. So technically, the main configuration file should just look for the config/automation.yaml file. It shows ZERO automations now.

It’s like it’s completely ignoring that file? I have the latest files (there are no updates showing as available).

Did you solve it? I just migrated a couple of automations as well after I noticed a suggestion to migrate them. Since the notification also suggested to remove the original files, I did that. And now these automations are not showing up. Even if I see them migrated in the config/automations.yaml file.

Have you included your automations.yaml file in your main configuration.yaml file?

automation: !include automations.yaml

Since you can only have one “automation:” line in configuration.yaml, there is a way to make it use your old manual files as well as the builtin UI (automations.yaml)

automation ui: !include automations.yaml
automation manual: !include_dir_merge_list automations/

You may need to change the “manual” line include to match what ever pattern you are currently using.

1 Like

Yup, exactly. My original automation definitions were in a subdirectory, and I have changed my configuration file to only look for automations there. After changing my configuration back, now all is good. :slight_smile: