Migrating from DeConz / ConBee II to ZHA / SkyConnect

I have an existing Zigbee network that has ~10 devices and I’d rather not open wall sockets and ceilings to re-pair my existing devices.

I’ve followed Migrate a deCONZ network using ZHA but things don’t go as expected.

On step 6, I add the ZHA integration, but instead of getting to a point where Conbee II is detected (step 7), I immediately get a dialog asking for “Radio Type”:


At this point, if I choose deConz (the 3rd option), I get the a dialog for “Serial Port Settings”. I’m a new user so can’t put another image, but the dialog asks for serial device path, post speed (set to 115200) and data flow control, which has 3 options - hardware, software and “” (nothing), which is the default.

Whatever I do at this point, I can never get to the next step - I always get a “failed to connect” message. I tried both /dev/ttyACM0 and /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2599688-if00, etc. I tried with the ConBee service running and stopped, tried rebooting, etc.

Even more, I’m not sure why I need to specify all these parameters to discover ConBee - the Zigbee communication should be done by it (and I only need it up long enough to “copy” the existing pairing and then remove them to SkyConnect.

Note that I Just installed HA from docker.io under a new docker container - I might need to expose some host resources to the container.

Maybe I’m missing something…

Please advise. Thanks.