Migrating from Rpi4 to NUC - I'd love some troubleshooting help

Hello there :wave:

I have a HASS bare metal instance running on a Raspberry Pi 4. It’s fine, nothing too complicated, but I have decided to switch to a NUC. Backup and Restore, right?

WRONG (for some reason). The NUC is a bare metal installation for the sake of simplicity. What I would like is a working restored backup with my database intact. I could also just throw away the database because I have a working InfluxDB that properly survives the backup and restore, so if it comes down to that, I’ll bite the bullet. However, I’d prefer knowing why the hell it’s going wrong in the first place. So any help would be appreciated :heart:

Here’s what happens (reliably, every time).

  1. I take a backup from my RPi4. Doesn’t matter if I manually triggered it or if it’s created by the Google Drive or OneDrive addons. I shut the RPi4 down and unplug it. I switch the LAN and z2m coordinator from the RPi4 to the NUC.
  2. I start the NUC and restore the backup on the NUC via the HASS backup restoration UI. The backup is successfully restored, the UI is actually available stupid fast (yay NUC).
  3. Startup, however, takes ages. The reason is the recorder - it never starts. And (probably because it’s first in my configuration.yaml) that holds everything else up. For around 5 minutes or so, even the Settings menu doesn’t contain the “Backups” entry (which was quite frightening the first time).
  4. Eventually, HASS gives up and starts up everything else, but it’s pretty messed up.

Here’s a link to the entire log. It’s full of problems, but the first one I think is mostly to blame here is this:

2023-12-19 15:54:11.678 ERROR (Recorder) [homeassistant.components.recorder.core] Error during connection setup: (MySQLdb.OperationalError) (2005, “Unknown server host ‘core-mariadb’ (-3)”)

(Background on this error at: Error Messages — SQLAlchemy 2.0 Documentation) (retrying in 3 seconds)

Now, essentially, very little actually works. The Shelly integration works fine. zigbee2mqtt is running fine (the addon itself), and via the addon UI I can interact with all the zigbee devices, so that got restored fine, too. But the HASS UI doesn’t seem to have access to much of anything except the Shellys.

Some more details:

  • the mariadb addon starts fine and reports no problems in the log
  • the phpmyadmin addon does not start, making me think that the database is broken
  • weirdly, the grafana addon also does not start

So all in all, there seems to be some kind of connection issue between HASS itself and all the other stuff going on.

Help? :slight_smile:

Unfortunately, nothing ever came from this thread, and while I can’t say I know what happened or why it went wrong in the first place, this is now solved.

I re-etched. That’s it. For good measure, I used a different USB drive to run the live Linux on. From what I can tell, everything went exactly like last time, except obviously it didn’t because this time everything works well and last time nothing worked.

Eureka, I guess? :sweat_smile: