Migrating from Virtual Machine to Raspberry pi4

Tags: #<Tag:0x00007fc4176ccba8>

I have had Home Assistant running on a virtual machine on my Windows 10 PC for the past year. I have decided I prefer to have my HA install on a dedicated always on Pi4 instead.

I am able to install HA on the pi4 via SD card with no problem. My problem lies with trying to restore my snapshot from my VM. I have never migrated HA to anything before and had/have assumed I can simply restore a snapshot on a new install and be good to go.

When I restore the snapshot HA disconnects and then does nothing. I assume it is loading the snapshot and installing it while this is taking place. Thus I have let it sit overnight several times now hoping to have access to it the next day but with no luck. I have waited 18hours and then yesterday it went for about 15 hours.

I see the HA ip on my network so I know it is on, but, nothing loads when I try to go to the ip address.

At this point I am figuring my assumptions on migrating are not correct. I have found plenty of documentation and videos on how to go from a pi to a VM, but I have not been able to find anything on how to go from a VM to a pi…

What am I doing wrong? Am I not waiting long enough? It seems like 18 hours is significantly more time than it would need.

I have tried restoring the snapshot when I first install HA on the pi in the initial login screen and I have tried to restore the snapshot using a google drive backup HA app. Both attempts yield the same results.

The snapshot was taken after updating my original HA to the latest and I am using the latest image for the pi 4 found here: https://www.home-assistant.io/hassio/installation/

hi,
i never got a rpi or windows with HA running, i’ m on debian/docker on a nuc …
but i ll try to help u.
You should look at logs, maybe there is something revelant. maybe something about files permissions or …
All i have to do to, move or backup all my hassio install, is to save the folder “/config”.
so i have a fresh install of hassio working, i copy the /config from my old install, i reboot …and voila.

1 Like

Hi @tgmm82, did you successfully migrate from your VM to the PI? I am having the same issue and any help would be sooo welcome.

+1, @tgmm82, having the same issue and any help would be appreciated.

Thank!