Migrating Home Assistant Supervised (Synology DSM) to RPi 4

I’ve been running Home Assistant Supervised on my Synology NAS until now, but since it’s no longer supported, I’m looking into alternatives to run HA on - either a Raspberry Pi, or the suggested Docker solution.

To be honest I’m not the most savvy with these things, and it took no small effort to get it running on the Synology to begin with (which I thought was already using Docker anyway, so the “Docker solution” as an alternative confuses me).
So I figured my best bet is to run it in a Pi this time, since that seems to be the de facto hardware standard.

But I’ll need to move my current instance of Home Assistant naturally, so does anyone know how seamless a transfer from the Supervised installation to a Pi would be?
Do I simply install HA on the Pi and restore a current snapshot?

I’m also using a Z-Wave USB stick, which I’m hoping would work painlessly with the transfer, but I really can’t be sure, so I would appreciate any kind of advice here. Thanks in advance!

Correct. That is how to do it.

Thanks very much!

My snapshots include everything such as my add-ons (Node Red, Mosquitto broker, etc).
Do I still have to first install the add-ons on my destination device, or just restore the snapshot to a clean HA installation?

I’ve been having some difficulty getting the snapshot restored, and I guess I’m probably doing something wrong, and could really use some help here.

In summary, I want to move from the HA Supervised on Synology DSM that I’ve been running fine but is no longer supported, to a recommended solution that would be more supported long term, and doesn’t break my existing setup.

Looking at my options, I figure the simplest would be to install HA Operating System on a Raspberry Pi 4 4GB model. I flash the Pi4 32-bit version to my SD card, and I get to the onboarding page fine.

Here’s where I hit a roadblock, as I can’t seem to restore the snapshot from my existing HA instance. Each time I do so, after I’m prompted to select what to restore, and I hit restore, it just loses connection and never reconnects. I’m aware the restore might take a while, but I’ve waited between 0.5-2 hours each time on my 211MB snapshot, to no avail.

I’ve tried restoring everything, only the configuration + NodeRED, and some combinations in-between.
I’ve tried restoring from the “Alternatively you can restore from a previous snapshot” link from the onboarding page, and I’ve tried setting up a new account and restoring from the Supervisor in UI instead.

None of them have worked.

This is the prompt I get when I upload my snapshot.
hassio_restore

Am I doing something wrong? Should I be installing the add-ons individually first before restoring?

Am I even using the right installation (HA OS)?
I’ll probably only use the add-ons shown here (Node-RED, Duck DNS and MQTT), and if those have no problems running on HA OS that works for me.

I realise I might be asking really fundamental questions here, but I’ve always enjoyed using HA to create automations in Node-RED, it’s just the installation and setup of HA itself that’s always confounded me, so thanks in advance for any help.

Hoping someone can help me here. I really need to migrate my instance of HA, but the restore snapshot just doesn’t seem to work for me.

No matter what I choose to restore, or where I do it from (during Onboarding or UI > Supervisor), it never seems to accomplish the restore properly, and I cannot reconnect to HA OS after that. I’ve waited over an hour each time.

My current setup:
HA Supervised on Synology DSM (which is no longer supported)
Home Assistant 0.118.5
Add-ons: Duck DNS, Mosquitto, NodeRED

Destination:
Home Assistant OS on Raspberry Pi 4 4GB

My current HA configuration is the result of several months worth of work integrating and organizing devices (including Z-Wave), and many flows in NodeRED, which I would very much want to avoid having to do all over again.

Unfortunately the lack of support means certain add-ons have already stopped working (I’ve lost the Alexa Smart Home Skill integration cause Duck DNS has been disabled), so this migration is quite necessary.

But it’s really quite distressing that I can’t seem to do migrate my current HA at all, and I’d appreciate any help or advice on anything that I could do to make this work.