Migrating to SkyConnection impossible due to USB port error


after the new homeassistant core version was released yesterday, I tried to migrate to the new SkyConnect device by following the process like this:

Open ZHA Config
Screenshot of Safari (02-02-23, 12-03-41)

Start Radio Migration

Select to move to a new device

Yes, I would like to proceed :slight_smile:

Remove old device (in my case Conbee)

Choose serial port of Skyconnect (plugged into homeassistant blue)

Select Radio Type

Select Serial interface (ttyUSB1 is correct, so I left it like it is)

Then the error occurs

Any ideas what the problem could be? Thx. Ike.

SkyConnect is for sure not deCONZ, as only Conbee and Raspbee are. However, I don‘t know the required protocol, spec says it’s based on EFR32MG21.

Thanks for the hint. I tried from top to bottom. None are working :frowning:

The footnote on the product page reads:

1: Relies on the experimental EmberZNet support in Zigbee2MQTT.

So, looks like ZHA is out-of-luck as of today.

SkyConnect works with zha.

The foot note is only a warning that z2m support is considered experimental.

Ezsp is the correct option for skyconnect.

Unfortunately I don’t know why the connection fails.

Have you tried in a different port?

Thanks everyone for the reply. I tried to follow this page: https://skyconnect.home-assistant.io and I also moved to another USB port.

Could there be an issue with my server? The config is also still under Hardware and not through the integrations page. :roll_eyes:

I got it working and one should follow the documentation :slight_smile: There it says:


To use Zigbee with ZHA configure the Integration as follows:

  1. Remember/copy the hostname of the add-on (e.g. c8f00288-silabs-multiprotocol).
  2. Add the Zigbee Home Automation (ZHA) integration to Home Assistant Core
  3. When asked for the Serial Device Path, choose Enter Manually.
    4. Choose EZSP as Radio type.
    5. As serial path, enter socket://<hostname-from-above>:9999.
    6. Port speed and flow control don’t matter.
  4. Press Submit. Adding ZHA should succeed and you should be able to use ZHA as if using any other supported radio type.

And boom, the migration worked fine.

I am assuming you did not have ZHA before installed? for those of us attempting to migrate from Sonoff or similar that already has the ZHA configuration installed, we cannot add it again. I am unclear what the migration path is for us in such a case.

I did have the ZHA integration installed.