Migration to Zwave JS - how to reinterview sleeping devices

Hi. Yesterday i have migrated from OpenZwave to ZwaveJS (not ZwaveJS2MQTT). Im quite happy with the ZwaveJS - seems that it already has a much wider hardware support than OZW - but i’ve got an issue with devices which were sleeping during the initial ZJS interview process. Now all those devices are “Unknown”, and even if i wake them up manually - i can see that the device woke up in ZJS log - it doesnt get interviewed and stays as “unknown node”.
On discord ive been advised to use ZJS2M instead, as it has an option to reinterview node, but i have already spent the whole day yesterday renaming few hundred entities and really don’t want to do that again. In fact, i have installed ZJS2M already, run it and it interviewed all the nodes, but ZJS integration does not pick up those devices in ZJS2M.
Therefore my question is - is it possible to reinterview unknown nodes in ZJS (not 2MQTT) somehow, like through editing cache files?

When im waking up an “unknown node” im just getting:

2021-04-10T11:08:52.304Z CNTRLR « [Node 021] received wakeup notification
2021-04-10T11:08:52.307Z CNTRLR   [Node 021] The node is now awake.

no attempts to reinterview it

I have switched back and forth multiple times and only had to rename them one of the very first Zwave js integration releases. You should leave the zwave_js integration there under configuration > integrations and fire up Zwave 2mqtt then click the plus as if adding another Zwave_js integration… then on the first box uncheck the option to use Zwave_js add-on (I believe) and enter the path to zwavejs2mqtt on the next box as mentioned in that add-one documenting ws://asomething

Sorry if that’s not super clear, just got off an overnight and I’m exhausted… you should be able to find some more posts mentioning how to switch between the two… if I can find one I’ll edit this.

Also, if there is a method to Re-interview in Zwave_js someone else will have to chime in as I haven’t been back to that in a bit

Not much of a better explanation but slightly more eloquent :grimacing:

Hi Bartem. Thanks for the thorough answer. The problem is that i have added ZJS integration with default values (for ZJS addon) and i cannot change that without removing and re-adding the integration, what will probably delete all my renamed entities too

Just add another as mentioned and it will change the exsisting one without adding a second one. (At least that was the behavior a few weeks ago)

Indeed, it worked, thanks!
Got a warning that the integration is already set up, but still it worked.

1 Like

when i changed to zwavejs2mqtt as expected all the naming of the nodes got totally screwed up and i had to remap all the references across my config.
ended up making a table in notepad between old and new and then some search and replace in each config file.

ended up doing this several times as i changed things.
not fun at all and honestly i’m not too happy about the auto naming of all devices and entities, there is no stability in the naming.

Hi. Just so you know i have managed to switch between ZJS and ZJS2M without renaming the entities again (Thank God for that, as yesterday i have spent whole day renaming few hundred entities, as almost all the defaults dont match my existing schema). If you will keep the existing integration from ZJS and then stop ZJS, enable port 3000 in ZJS2M addon settings, run ZJS2M, create a new ZJS integration, uncheck the box, enter ws://localhost:3000, it will throw out an error that the integration already exist… but the old integration starts behaving like it would be created with the box unchecked allowing ZJS2M to use already devices already created by ZJS.