Mini Graph Card opens javascript file instead of the graph

I installed the mini graph card bt HACS,
Automaticly added the folder in my lovelace config.

But when clicking on the “open plugin” button in HACS, it opens the .js as a .txt (8123/community_plugin/mini-graph-card/mini-graph-card-bundle.js)

In my lovelace this folder is configged, and custom_header works normally

  - type: module
    url: /community_plugin/custom-header/custom-header.js
  - type: module
    url: /community_plugin/mini-graph-card/mini-graph-card-bundle.js

How to get the mini graph’s to work?

so it looks like an HACS issue, isn’t it?
have you tried to ask in its topic or open a new issue on Github?

You need to create a card and add it to lovelace via raw config editor or yaml.

Code for above card:

align_header: left
align_icon: left
align_state: right
animate: true
cache: true
  - color: green
    entity: sensor.mbps_received
    index: 0
    name: RT-AC88U Download Speed
    state_adaptive_color: true
  - entity: sensor.mbps_sent
    index: 1
    name: RT-AC88U Upload Speed
    state_adaptive_color: true
height: 150
hours_to_show: 6
points_per_hour: 8
  icon: false
  labels: true
  labels_secondary: true
show_state: true
smoothing: true
type: 'custom:mini-graph-card'

1 Like

You can also add it by selecting “manual card” in the UI.

1 Like

Thanks Tom, that’s actually the route I should have suggested based on the question.

I feel such a fool… I tried it, but with a intend issue… therefore also my graph didn’t work…

But NOW it does! Thank you!