Minimal android app

Currently I am starting to use my new phone with GrapheneOS. But I’ve been having issues connecting with my home assistant instalation.

I’ve tried a instalation from f-droid and dicectly from git but until now no succes.

The app instals and I will get the setup screen and get to the screen where you can connect to a home assistant server. It even recognizes my adress. Unfortunatly the screen turns solid white after clicking on the server.

I also tried the local adress but also no luck.

Is this a known issue? Or am I doing something wrong?

App version 2024.4.1-minimal
Home assistant 2024.5.1

Install Google’s version of Android system WebView and set it as the default WebView in your device settings. Unfortunately custom roms typically don’t ship with compatible WebView

1 Like

Thank you for your fast reply!!

Unfortunately I can not change the WebView. GrapheneOS only runs Valadium WebView (fork of Chromium and webview based on the WebView by Google). There is no option to change this :frowning: .

Hopefully there will be a fix aviable for this shortly. Untill then I can not use my new phone.

It’s not going to come from the app. Are you positive you can’t change it. Every custom rom user I ran into has been able to change the default WebView. Even ones on graphene.

1 Like

I’ve found the issue! It was completely my own fault.

The GrapheneOS default Valadium browser and WebView are working perfectly combined with the minimal companion app!

The local adress I tried to connect to was not reachable due to my VPN which had incorrect split tunneling rules :sweat_smile:. The only thing is I did not get an connection issue message during the time the screen was on…

I’m sorry for the confusion I’ve caused but for me most of the functions are working now.

Thanks for your support!