Minimalist ui not working since 2023.12


I updated yesterday to 2023.12 and all my minimalist cards stopped working. On my desktop I just see nothing, on the mobile app I see an error message

ButtonCardJSTemplateError: TypeError: Cannot read properties of undefined (reading 'match') in 'var number = hass.resources[hass['language']] ["ui.duration.hour"]; var matches = number.match(/[...'

and what seems to be the code of the card behind that…

Does anyone know what that means? Thanks for your help.


Did you have the integration installed ?

After installation and UI reload this solve the issue for me.

I don’t know what you mean with your question weather I have it installed…
I have minimalist ui installed in HACS and have the integration configured. I used this for quite some time and I wrote ‘stopped working’ - which implied that it worked before. So if you mean that I can answer yes, in case you mean something different can you please be more specific?

I personally have installed it manually and not via HACS and the integration wasn’t present visually in Parameters and it stopped working after 2023.12 with the same error message.
So our installations are not the same but error seems similar.

Maybe try to reload / reconfigure it / change some configuration parameters (language ?) if you didn’t already tried it.

Hi @4nduril, I have the same issue, have you found the resolution?

I disabled the loading of needed resources and that worked. I only had to ensure all needed dependencies are installed.

Hi @4nduril, could you please give me some more details about how you solved this? I’m facing the exact same problem and I still don’t know how to solve it.