Mirabella Genio Smart Home

Hi all,

Purchased a couple of these lights (1002607 Wifi LED GLS, 9W 75mA RGBW +2700K) from Woolies hoping to flash them, but alas it isn’t going to happen. Have dismantled one hoping to program directly via serial, however, the internals are completely different from the ones shown in this thread.

I’m hoping these images help someone!

Any chance you could post some more images of the chip at the bottom left. even scrape some of the white muck away and we can see the chip details


Will not flash with Tuya-convert :frowning:

https://docs.tuya.com/en/iot/device-development/module/wifi-module/wifilc5module?id=K9605t3bpxf75

Hope the link helps.

The pads to flash are there. Tx Rx just need to solder a wire to those pads.

if anyone has got the Mirabella I002607 RGBW Bulbs from Woolies. I have managed to finally get them to flash and into home assistant.
Step 1
Flash in you preferred method to get to tasmota.bin file on the globe. I used the OTA method for Tuya i used this video.


thanks digiblurDIY.
Step 2
Once i got into the Globes sonoff web page page. i update to latest firmware
Step 3
i went into configure Module
chose Generic(18)
D6 GPIO12 Relay1 SM2135 Dat (181)
D5 GPIO14 Sensor SM2135 Clk (180)
saved
Step 4
added my MQTT information
saved
Step 5
went into the console
setoption19 1
Step 6
then added the globe to lovelace

Happy Flashing

just posted bellow a method to do this

1 Like

I must be missing something… I’ve reset my pi up from scratch, tried combinations of 3 and 5 cycles on the bulbs, donor phone attached, pi right beside globe, I cant get these bulbs to connect.

Any tips? Not super keen to flash with serial device, but at this stage I’m running out of ideas/

Thanks Guys!

It took me 3 attempts last night. It was really random how many times I had to turn the bulb off and on to get it into flash mode. The second attempt was a slow blinking which did not work at all. Third attempt was fast blinking which then worked.
Latest tuya-convert. RGBW bulb from the recent Woolies sale. Flashed ESPHome with the custom component needed for that new chip (edit: sm2135).

@exxamalte were these the ones in the cardboard boxes or the plastic clam-shell packaging?

In a cardboard box, model number I002607.

I have purchased a few of the white only globes and I have discovered that only the “Cool White E27” appear to have an ESP8266 that can be flashed. The “Warm White” do not have the ESP8266 by the looks of it (Realtek chip ?), at least that is my conclusion. The “Cool White” packaging was not wrapped in plastic compared to the “Warm White” which were.

I have purchased Genio Warm White (1002332) and Genio Colour Changing + Warm White (1002338) bulbs. Both are in wrapped in clear plastics.

I able to flash both lamps with with Tasmota. And I also have configured colour bulb (1002338) with this Blakadder template.

Now I need ESPHome yaml file for these two bulbs. Can you share yaml files?

Thanks

Hi all! First time poster here, thank you for all the information from you all so far!

I have just flashed one of the genio motion sensors OTA with tasmota. Very easy process, however, I too had to use a power source rather than batteries or else it would fail. I then used the template, ran the console commands plus a few random ones on various forums and then added a binary sensor to my config.yaml. The sensor itself works on batteries but none of the other entities that sensor creates does.

So far I have the sensor showing up as a normal motion icon within HA, motion is being reported (on batteries). I want to use the sensor with automations but it doesnt show up as a binary motion sensor when selecting “Use motion to turn on lights” etc. I have tried a manual state but don’t know what to input in the to/from etc. Does anyone know how to get the sensor to show up with the hue sensors when selecting an automation etc??

Thanks!

I purchased the warm white I002604 and can’t get it to flash tasmota via Tuya convert. When putting it under pairing mode (blinking fast) and setting my phone as a donor, I can see it stops blinking once I hit enter on the tuya convert but then it doesn’t go any further.

G’Day all, new to HA+ESPHome.
I’ve picked up a Genio RGBW 1002339 and successfully flashed ESPHome using the cookbook.
It appears in HA but the bulb is unresponsive to any colour changes. Twice, at random, I’ve manged to get it full bright white, no idea how or why.
After a power cycle the bulb still does not turn on despite the setting “RESTORE_DEFAULT_ON”

EDIT: I’ve just tried Tasmota firmware and this template https://templates.blakadder.com/mirabella_genio_1002338.html
The only time it turns on - warm white light - is with the sliders in this position. Any other setting has zero output. Can’t change brightness either.
tasmota_ww

esphome:
  name: genio_rgbw_1
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: 'xx'
  password: 'xx'

logger:

api:

ota:

web_server:
  port: 80

output:
  - platform: esp8266_pwm
    id: output_red
    pin: GPIO4
  - platform: esp8266_pwm
    id: output_green
    pin: GPIO12
  - platform: esp8266_pwm
    id: output_blue
    pin: GPIO14
  - platform: esp8266_pwm
    id: output_white
    pin: GPIO5

light:
  - platform: rgbw
    name: "genio_rgbw_1"
    red: output_red
    green: output_green
    blue: output_blue
    white: output_white

    # Ensure the light turns on by default if the physical switch is actuated.
    restore_mode: RESTORE_DEFAULT_ON 

Thanks

You beauty!
Genio RGBW B22 1002339 (plastic clam-shell packaging)
This seems to get it going:
{“NAME”:“MI-BW906-999W”,“GPIO”:[0,0,0,0,0,0,0,0,181,0,180,0,0],“FLAG”:0,“BASE”:18}
setoption37 31

EDIT:Yet somehow I missed the template page which would have saved me all of the headache…

I’m new here (I set up my HA instance only a week or so ago) but I did manage to get the new Mirabella RGBW globes with the sm2135 chip working with ESPhome. I could have chosen a slightly easier device for my first attempt at flashing ESPhome, but anyway, got there eventually.

I used the sm2135 custom component linked above but replaced the sm2135.cpp file with this one:

https://github.com/CaptainLeezee/HA_BitsPieces/blob/dd34093374f0453346f5aae92206d772f7a9db1e/sm2135/sm2135.cpp

Then used this yaml file:

https://github.com/CaptainLeezee/HA_BitsPieces/blob/dd34093374f0453346f5aae92206d772f7a9db1e/ESPHome/config/mirabellaGenioRGBW_V2.yaml

It’s not perfect but the altered driver fixes some weird behaviour with the ww/cw settings. It’s definitely useable and I think the main issues are ww/cw balance (seems to be more like a switch now) and the saturation slider in lovelace didn’t work (but you can still desaturate colours using the colour wheel).

Let us know how it goes.

1 Like

I resetup my HomeAssistant FROM SCRATCH

I am now stuck, with a Genio Mirabella light section but I can’t change colour, just brightness?
It’s like the colour spectrum adjustment control UI element is missing / broken?

This is the new, crappy UI

This is my old one.

What have I done wrong?

Settings > Customize > Find respective entity > Set “supported_features” to 63