Mirabella Genio Smart Home

Kmart (Australia) have started selling resonably plriced smart bulbs and plugs under the Mirabella Genio brand: https://mirabellagenio.net.au/

These are wifi enabled - similar to lifx. I have bought a couple the 800 lumen RGBW and the 800 lumen cool white to try.

They have Alexa and Google Home integration. Are any developers interested in adding them to the supported hardware for hassio? What is required to kick this off?

2 Likes

Do they work with this? I’ve seen a few people point this out with a bunch of different ones on the market here.

@cjsimmons Thanks for that - yes they are Tuya based.

For any Australians who have bought these and want them to work with Home Assistant (despite them being cloud controlled), you need to use the Tuya Smart app to set them up and create your cloud account, NOT the Mirabella Genio app. If you use the Genio app, Hass won’t be able to log into your account, as Genio is not a supported platform for the Tuya devices.

Set up your account using the Tuya Smart app and set up Hass as per the Tuya Home Assistant example.

2 Likes

I decided to go and get one of the smart plugs today to have a look. first thing i did once i bought it was open it up,
The teardown was easy, 2 screws on the back, carefully pried it open with an old credit card I use for things like this. and first thing I see is that it is an ESP 8266 chip so for anyone familiar with tasmota or any other firmware for sonoff devices should know that it should be hard.

After a quick poke on the internet I found a few posts: Pinout
this one gave me the clue for the pin out.
And this one: Tuya Flashing Instructions
gave me the config for tasmota.

Flashing was easy, had it pulled apart, flashed, back together and setup in HA (via MQTT) in about 20 mins (including taking a few photos and making notes!)

Not as cheap as a Sonoff, but I can go and buy it from 5 mins down the road and it is certified for use in Aus which is a good thing

2 Likes

There are some basic instructions up on the tasmota wiki now & I have had some success with a Genio bulb too. I hope to add that to the tasmota wiki soon.

@alfazon saw your post on the tasmota wiki - well done, will have to buy a couple now to flash

Also if you want a new challenge I saw these on the weekend:

https://www.bunnings.com.au/brilliant-smart-wifi-plug-and-usb-charger_p0091644

@zoogara, thanks!
They look just like the genio ones I’m guessing they would be the same process and they are slightly cheaper!

Ps. I have been able to flash the genio bulbs too now. I will post instructions when I get a chance.

1 Like

I’d love to see how you did it, did you dissasemble and solder wires to flash or did you figure out how to flash them OTA?

These Mirabella globes are about our cheapest option for locally available smart globes but I’d much rather have Tasmota firmware on them.

There is an OTA method:

If I get some spare time I’ll give it a go tonight.

For reference there are multiple brands selling the same Tuya products:

  • Mirabella Genio (Kmart and BigW, Kmart is cheaper)
  • Brilliant Smart (Bunnings)
  • Vivitar (JB Hifi but not listed on their website)

As far as I know Mirabella are the only source for globes so far, with Brilliant Smart and Vivitar only offering the smart plugs.

1 Like

I pulled them apart, I have never had much success with ota but I might have to give this a go too.
They are easy enough to pull apart.
As long as you have a soldering iron, a little patience, and a bit of force!
I still need to get time to write my wiki for it.

I’ve started my journey looking inside these bulbs. Here are some photos. Kinda hoping @afalzon can point out some solder points for me :slight_smile:

P.S. Just cos I pulled my bulb apart dosn’t mean you should. Its dangerous, warranty voiding and might injure or kill you. Don’t do it.

For note, I have had some success with this python library with a bulb straight from the package and setup via Genio app. I can query the bulb status. (But there are significant limitations).

Dictionary {'devId': '1468xxxxxxxxxxxx62b0', 'dps': {'1': True, '2': 255}}
state (bool, true is ON) True

Limitations include:

  • The discovery process is entirely manual and requires getting the ‘device id’ for the bulb out of the Genio app.
  • I can only read the status, as setting the status requires a ‘local key’ that I requires significant messing around to source.
  • The bulb only supports one connected management tool at a time. The script will not respond if the phone app is connected, and visa versa.

[This post has been updated] I’m going to see if I can create a reusable harness to press-fit wires onto the chip for re-flashing. No idea if this will work, but don’t want to destroy the bulb to get the WiFi module out.

Following these specs: https://fccid.io/2ANDL-TYWE3L/User-Manual/User-Manual-3894982

UPDATE: Darn it, my FTDI module is 5v. That’s put the breaks on for a bit.

UPDATE: Couldn’t decide on whether to us laser cutter or 3d printer to make wireing harness, then remembered that I didn’t have either. So after trying to make one by hand with card and a knife, I gave up and soldered the wires by hand:

UPDATE: Tried to flash, used RPi as a 3.3v PSU (bad idea?) I can power the chip and see it in the Gemio app, I can power chip with GPIO0 pulled to ground, I can no longer see it in app and I see garbage on the serial line. But no matter what I do I can’t get it to flash. The TX lights flash on my FTDI but nothing comes back and it fails. If anyone can help that would be awesome. @afalzon :slight_smile:

1 Like

Hey Mike, looks like you have done almost exactly what i did,

My FTDI has 3.3v i hooked up the wires and, connected GPIO0 to GND while plugging it all in and I used ESPEasy to flash, fom memory it took 2 or so goes for it to connect and flash.

Thanks, I’ll take a look at that flashing app, I’m using PlatformIO as a plugin to VSCode. How are you compiling the binary? (I’ve not flashed stuff like this before.)

im just using the standard tasmota bin, i am thinking of compiling my own but havent got to it yet.
Have a look at https://github.com/arendst/Sonoff-Tasmota/wiki/Mirabella-Genio-Smart-Plug
there is a link on there that will take you to a youtube video showing the method I use

1 Like

Have you had any luck yet?

I have tried with both MockTuyaCloud and TuyOTA and it looks like the update needs to be triggered.

So do you touch gpio0 to ground for a short period as you turn the chip on? If so how long, or do you keep ist connected to ground as you flash?

Hey Mike, I hold the GPIO0 to GND until I hear my PC do its normal “chime sound” when you connect a USB device, and until I see the serial port become available on my PC.