Missing cards on mobile devices

I’m having trouble seeing all the dashboard cards on my mobile devices.
They are all there when I use any browser on my PC but on the Overview Home tab on my Android phone, only the first card is visable. I get the same result with an Iphone and Ipad.
I have tried reinstalling the app and restoring HA to a previous version but it didn’t fix it.
PS The cards on the Temperature are ok ie all displayed
Any ideas ??
Screen shot of PC and Phone attached


Are you using any custom cards?

no just standard ones.
It has been working for a couple of month no problems but in the last week or two it has been all over the place. Could it be related to updates ?

No idea without error logs.

I’m having button card problems only. They don’t appear all the time. If I force close the app and restart it sometimes works and sometimes it doesn’t. Nothing weird in the logs though.

Some error log info
Is there anything specific I should look for

Can’t connect to ESPHome API for 192.168.1.162 @ 192.168.1.162: Error connecting to (‘192.168.1.162’, 6053): [Errno 113] Connect call failed (‘192.168.1.162’, 6053)

13:57:56 – (WARNING) /usr/local/lib/python3.9/site-packages/aioesphomeapi/reconnect_logic.py - message first occurred at 11:54:06 and shows up 5 times

[547400066720] Disconnected: Did not receive auth message within 10 seconds

13:55:24 – (WARNING) Home Assistant WebSocket API - message first occurred at 13:36:03 and shows up 4 times

Unable to find referenced entities switch.10011da2cf

13:54:38 – (WARNING) helpers/service.py - message first occurred at 11:54:43 and shows up 31 times

http://homeassistant.local:8123/hacsfiles/atomic-calendar-revive/atomic-calendar-revive.js?hacstag=246549747510:188:0 NotSupportedError: CustomElementRegistry.define: ‘mwc-linear-progress’ has already been defined as a custom element

13:49:41 – (ERROR) components/system_log/init.py - message first occurred at 12:08:48 and shows up 13 times

Error in ‘Charge Pat Phone’ trigger: In ‘numeric_state’ condition: no entity specified

13:49:01 – (WARNING) Home Assistant Core Integration

http://192.168.1.19:8123/hacsfiles/atomic-calendar-revive/atomic-calendar-revive.js:188:201 NotSupportedError: Cannot define multiple custom elements with the same tag name

13:45:28 – (ERROR) components/system_log/init.py

Login attempt or request with invalid authentication from android-e9057ebccf8f9463.lan (192.168.1.129). (Mozilla/5.0 (Linux; Android 8.0.0; ASUS_Z01HDA Build/OPR1.170623.026; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/95.0.4638.74 Mobile Safari/537.36)

13:42:03 – (WARNING) HTTP - message first occurred at 13:42:00 and shows up 2 times

Logger: homeassistant.components.webhook
Source: components/webhook/init.py:92
Integration: Webhook (documentation, issues)
First occurred: 11:53:42 (1 occurrences)
Last logged: 11:53:42

Received message for unregistered webhook 85f79e66733e87721404904feebabecdf72229aea818213db01dda245bc65dd3 from 192.168.1.129

I am seeing the same as you, one of my fire tablets (using fully) isn’t showing most of my cards, but other devices show everything fine.

Also my “dynamic” overview page that home assistant updates with every device only shows two cameras and none of my other devices. This happens on all my devices, I bet it’s related.

I just updated to the latest version, 2021.11.4 but I think I started seeing this once I went to the November update.

It’s not only mobile devices for me. Yesterday I opened up my laptop and was missing the same button as I’m missing on my mobile devices.

I feel it started with the November updates.
I’ll fire up an old version and see what happens

OK I booted my old system (Pi3) and it all worked so I have now downgrade my new system (pi4) to 2021.10.2
using ha core update --version 2021.10.2
and everything is working correctly.
I guess there is something strange about my setup that is causing issues for me.
Not sure what I’ll do next at least it is all working
Cheers Andy

When Tom_l asked you about custom cards, it was because it was a known problem since the November update with custom cards such as Atomic Calendar Revive potentially preventing the loading of core cards.

There’s a clear reference to this happening in your logs.

You should remove this card if you are not using it, or ensure that all your custom cards are up to date, as most of them have now been updated to address this issue.

What exactly do you mean by this? It occurs even with newly created cards. What do I need to change?

My reply was to andy135 because of the specific error showing in his logs.

Unless you are seeing the same error, what I advised him may not apply to you.

If you do have custom Lovelace cards installed, then how you update them will depend on how you installed them. Do you use HACS to install custom cards and components for example?

[EDiT] Sorry, further edit to make sure I’m being clear, and apologies if this is too simplistic: the distinction here is between core Lovelace cards that come with any HA installation, and additional custom Lovelace cards (such as Atomic Calendar Revive) that a user may choose to install, with the accompanying risk that they might break things.

Cheers Chris, I’m very new to HA and didn’t realiase I was using custom cards but now I look closer I’m starting to get it.
Thanks

Ok thanks for your explanation. My problem is with the Button card.