Missing Cloud option

Hi, I’ve recently managed to break my HA SmartThings integration after replacing my BT Smart Hub 2, due to its inability to actually reserve ip addresses. I changed my IP address range and as a result my Smartthings integration broke. I reinstalled it but it found no devices instead of the 100+ that should be there.

As a result I decided to totally rebuild and start again. I’ve refreshed an SD card and started from scratch, and the new instance has immediately linked to my Hue Bridge, but I’ve noticed that my configuration page is missing my cloud option so that I can reconfigure my Nabu Casa account, which I believe I need to re-setup my Smartthings integration.

I’ve searched for the correct thing to enable it, and added the line ‘cloud:’ to my configuration.yaml, but with no success. I do have

 # Configure a default setup of Home Assistant (frontend, api, etc)

at the top of my configuration.yaml, so tried commenting that out, and promptly broke all the other bits I was expecting to see, so it’s back in and now I’m a bit stuck…


I manager to get this working again after I deleted the production_auth.json from ./cloud dir.

1 Like

@gareth.cheyne that did not work for me either. did you do other stuff also because that was not the trick for me?

Have you got…


In your configuration.yaml file?

deleting production_auth.json and restarting worked for me. That logs you out of Nabu Casa and makes you log back in.

Hello, where do I find this file? production_auth.json
I miss my cloud too…