Missing command like socat on hassio

Hi, and thanks for your great work.

I’ve followed this tutorial https://www.home-assistant.io/getting-started/configuration to install hassio on a pi3.
which i succeeded.
I then tried to install a lms plugin to control my squeezebox via this tutorial

https://github.com/ynot123/LMS_Controls/blob/master/Installation%20Instructions.md .

I’m almost done but some key command are not available in the ssh. Like socat. I’ve tried to install it via apt get but this comand was also missing.

core-ssh:~# socat
-bash: socat: command not found
core-ssh:~# apt-get install socat
-bash: apt-get: command not found

Did i miss something during the install of hassio or, is there plugins to add common commands on ssh???

Thanks for your help.

From what I understand, the way you installed it, it is basically running in a docker container. ssh doesn’t have access to the host system only the docket container.
I don’t know what your squeezebox is but you may need to use an alternate install method.

Thanks for the answer. I tought it was the only way to install it on a pi3.

which kind of install will you recommend to have it on a pi3?

i’ve looked further, i’ve install what is called hassio. do you thing the problem comes from here? it was presented like the best way to do so…
if find apparently an other solution which is hassbian…
do you thing it will solve my problem??

or do you have an other solution?

You can use Hassbian. This is more like a standard pi image.

It’s not exactly the same but closer. It might be better.
I am no expert, I am still learning HA also. I have it running on a VM.

I’m already writing the image i would see…

if somebody have an easy fix for hassio it will spare me the time of redoing all the lms process…

Anyway thanks i will give a try at hasbian

If you still have your hassio config files, you can just pop them into the hassbian config folder and most of the work will already be done.
The yaml files are interchangeable on all of the installations.

That was what i was hoping for :slight_smile:


I’ve install hassbian but i didn’t realize that i would not have the addon store any more coparing to hassio. So i think this solution is out of my reach… in order to install samba/configuration/duckdns and all… so anyone has a solution do add socat command in my hassio install?

All of the options are available, they just are not as easy as clicking the addon in the store.
sudo apt-get install samba
and you can setup your share. etc.

I’ve tried but setting up without hassio is a bit to much for me…I encounter few problems…
anyone has a idea how to add socat to hassio??

No ideas yet but i intend to use rfxtrx on Home Assistant via network… any suggestions welcome.
I already use rflink and dsmr via network using ser2net on a Pi, works fine. But those already support network in the yaml config out of the box.

I now see three approaches to this:

  1. run socat on hassio to make HA think its a local device.
    (this topic)

  2. use node-red to connect rfxcom
    I suppose thats https://flows.nodered.org/node/node-red-contrib-rfxcom and HA must use mqtt to talk to it.
    (sounds like a lot of overhead configuration)

  3. someone implements network support.
    I never use Python …but im willing to dive into this. :slight_smile:
    So i created this topic for that: Adding network to rfxtrx component

1 Like

Using remote serial devices should be way easier…vote for native socat support in HA: