Missing device in MEROSS LAN, when adding it complaints of "Device is already configured"

Hi to all,

I have been using HA for a few months, so still pretty newbie. I am running HA2021.10.4 in a docker container in a PI4, with the MEROSS LAN 2.3.3 installed through HACS. After I started using it, I bought more MEROSS devices, as I really liked the integration. Up to now I have 2 MSL120D, 4 MSS310, an MSH300 and 10 MSS710.

However, after a short electricity blackout, some were missing. After a while, most reappeared nicely in the MEROSS LAN integration. I also went back to the router and added fixed IPs to all the devices. However there is one missing device. I know the IP it works with the Meross phone app, and in fact it is periodically discovered by HA (“We have discovered new devices on your network.”). However, it appears in the integrations as an additional MEROSS LAN box, and when I try to add it, it complains that “only one device possible”. I tried forcing to connect using the meross password instead of the hack, but it gives the same result.

Even more surprising: after another blackout, that device was discovered fine, and now it is another one of the same type the one that does not appear, gets discovered by HA, and cannot be added because it says “only one device possible” (again, it works ok with the Meross app).

Any hint would be very welcome.


Finally solved.

I had to turn the log level on the custom.meross_lan integration to “debug”, find the IPs of the devices that gave problems in the log, and found there which unique_id they had.

They went to .storage, and deleted every entry in every file corresponding to those devices. After that, restarting homeassistant found the missing ones, and allowed to add them in the usual way.


Hello , I have same problem, I had to reset my lan and now I cannot add meross devices anymore, it continue to say device is already registered. could you help me indicating the passages I have to do. i don’t know how to accomplish the debug , storage etc. thank you for the help

Same issue here. I don’t know how to delete entries involved. Please i need some help.

Sorry, it was some time since I did this.

Some more details. To turn the log on add to configuration.yaml:

  default: info
    custom_components.meross_lan: debug

Look for the log in the home assistant log list (in my version it is under configuration/logs).
If I recall correctly, in the log there will be the IP of the device together with a unique_id field. Write those down.
Then open a shell to the home instance folder. I am using a docker container so I need to do:

docker exec -it $(docker ps -f name=homeassistant -q) bash

There change to the .storage folder. There look for the unique_id entries, and delete those lines. To find them, you might want to use egrep .
And finally restart home assistant.

Thanks a bunch @Juanfiba! :slight_smile:

In case this helps anyone, I managed to fix it with the following:

Install the terminal add-on if you don’t have it already

cd ~/config/.storage

Then enter the entries file:

nano core.config_entries

In this file will be all the Meross devices with their IP-address and MAC-address.
Try to find a record that says “domain”: “meross_lan” but does not have an IP-address.
Delete that whole element en reboot Home Assistant.

Home Assistant detected the device on boot in my case and I was able to add it succesfully


@Juanfiba wondering, are you able to manage the RGB/color of the MSL120D bulbs via HA? I just got a pack of these and started integrating them into HA, however I’m not seeing how to manage the color of the bulb from HA. I’m not using the Cloud so that may be a difference from your setup.

Never mind, after I had waited for my HA update to finish and reboot I checked the Dashboard card and I do see the ability to control the color and temperature from the popup.