Missing openssl - how to get it installed?

Hi, I am absolutely new to HA and have it just installed on my Raspberry!
Running Node Red the log came back, sayin the ssl certificate is missing. Since I am running within the bounds of my own network I was thinking the issue my own certificate… Terminal & SSH is installed in HA, so I went for the terminal trying to run openssl, just that the command is unknown. Installing it trough apt failed, since apt is also not known.

Can you enlighten me how I get the stuff done? I guess we can agree on the Linux running in the background - what am I missing here?

Bests Thomas

The fact that HA OS is considered an appliance, you can’t install anything on HA OS, except add-ons.

Raspberry OS is not supported, but you can install Debian on a Pi. However, many have nodered running on HA OS, did you try to install the add-on ?

Sorry Francis, what add-on are you talking about?

Well that’s the one I installed, but the log file complains about the non-existing pem file in the ssl directory. Would Node RED run when adjusting the config to ssl: false?

Yes it will.

Just to confirm Francis, I set ssl to false, and will I have to adjust/delete the keyfile option or will that be ignored when setting ssl to false? Any other options to adjust when setting ssl to false?

Nothing to adjust.

Thanks so much for your fast help!

This is how you install openssl:

[core-ssh ~]$ apk add openssl
fetch https://dl-cdn.alpinelinux.org/alpine/v3.16/main/x86_64/APKINDEX.tar.gz
fetch https://dl-cdn.alpinelinux.org/alpine/v3.16/community/x86_64/APKINDEX.tar.gz
(1/1) Installing openssl (1.1.1q-r0)
Executing busybox-1.35.0-r15.trigger
OK: 96 MiB in 98 packages
[core-ssh ~]$ openssl
OpenSSL> exit
[core-ssh ~]$ 


Is there a way to specify that my integration needs openssl?
For instance among the requirements inside the manifest.json?