Missing sidebar items but add on is running

I run Home Assistant in a VM. Some time ago, I upgraded home assistant, I noticed that the some items in home assistant sidebar was missing (red box below). However, I could see that the corresponding addon was running. Those missing item came back after I restart the home assistant (restart server in home assistant website, not restarting the VM).

I am new to HA and I don’t know what happen or how to debug it. Can anyone kindly help me?

Since this is my first post, I couldn’t attach 2 pictures. here is when HA first loaded

This can happen when browser session does not refresh. You should only worry if it happens consistently.

thank @os.habitats.tech. how do I let the browser refresh? I am using chrome I tried clear the cache. But it didn’t seem to solve the problem. Another data point is that, the andriod app has the same issue.

On PCs is ctrl+F5. You can also reboot HA which will start a new fresh session. Try also an incognito/private browser session.

It is somewhat annoying to login again after restarting the server because it happens everytime I restart the VM. I am still playing with it and does restart a lot to iron out a boot problem when Coral USB is plugged in. But I appreciate your help.

It’s happening to me consistently when the PC running Home Assistant (on VM) reboots. I have to restart Home Assistant after boot to refresh everything.

  • Core2024.1.1
  • Supervisor2023.12.0
  • Operating System11.3
  • Frontend20240104.0

i have the same Problem. Running as VM in Proxmox.

After Restart all Addons a visible and than sometimes all Addons are invisible on Web and HA App (iOS)