Missing SUPERVISOR on HA in Synology docker

I installed HA in docker on Synology NAS. Now I need an integration, learned a lot of stuff and seen many movies. However, it seems I need Supervisor menu item, which is missing.

Yes, I know, it has been integrated with Setting, as many frustrated posts claim. But even in Settings there is no Add-ons possibility.

I already have problems with EVERY item I try, Every step I make means weeks of study. I think this is absurd. And now it seems there are many different HA too.

If this is not working I give up on any home automation. It’s just impossible to do.
Even worse, I am a programmer and can’t even find out!

Please read: Installation - Home Assistant

You’ve installed a docker version and HA has NO SUPERVISOR in docker.

Consider using a VM on your Synology NAS and INSTALL Home Assistant Operating System


Home Assistant Operating System: Minimal Operating System optimized to power Home Assistant. It comes with Supervisor to manage Home Assistant Core and Add-ons. Recommended installation method.

You installed :

Home Assistant Container: Standalone container-based installation of Home Assistant Core (e.g. Docker). that has no supervisor.

Not to be a dick, but if you couldn’t find this by yourself, you’ll get frustrated a lot as soon as you installed the correct version. HA takes a lot of time to learn fully

1 Like

And that sounds a bit rude, there is absolutely no reason to start shouting, especially in your first post here :thinking:
After all, it is not our fault you installed the wrong system because you did not take the time to read and find out the differences between the available installation methods :face_with_monocle:

I mean, which part of this diagram you didn’t understand??

And apparently it doesn’t matter you’re a programmer, as it seems programmers don’t have a clue anymore how a computer works anyways, so what is the relevance of mentioning it?


I intalled a VM with Home Asistant OS. Don’t see any supervisor, but did find the needed item.
So… now I have to add a repository: GitHub - briancmpbll/home_assistant_custom_envoy
Guess what: Doesn’t work, only getting this error:
GitHub - briancmpbll/home_assistant_custom_envoy is not a valid add-on repository

Tried to solve this, but of cause… No reason why this should be wrong. So another hard stop… (Tried from the Add-on store, three dots top right)

BTW, I’ve been trying and trying for weeks now, so obvious I get frustrated. This whole landcape is only made for extreme hackers. And since the UI changes so rapidly and there are so many different HA versions, there is not much help from older webites nor youtube video. Anyone wanting HA must redefine the path and reinvent everything. That’s why I shouted.

Have you installed HACS?

And that error is normal. An add-on is not the same as a custom integration. You try to install a repository for a custom integration into the add-on store, and guess what ? that does not work, because it is not an add-on.

It’s true some youtube video’s don’t apply anymore or things are changed, but it is not just for extreme hackers. My 60 year old dad got me into Home Assistant and he is far from an extreme hacker. It just takes a learning curve. Check out some videos from

Smarthome Junkie
Mark Watt Tech

A steep learning curve indeed. I’m getting better, but I see there were decissions made in the past that have made the program irrationally difficult.
Would have been better to start all over knowing what ‘we’ now know, instrad of changes over changes…
Now I need global and local variables, but of cause global ones are non existent, so have to add the hass-variable github to the integrations - you can almost guess: that menu item is not available (it is on the add-ons)
I asked a question somewhere else for where that menu item has gone to (if it ever existed, that is)

What decisions? Home Assistant has been evolving into a more user-friendly, GUI-based approach over the last years. It’s getting easier and easier to start using it.

I feel your approach is irrational, not decisions made by the the developers.

If you actually want help start by answering the questions that are raised in this thread.

Au contraire mon ami…it became a lot easier compared to 3 years ago…a lot of functions before only available in yaml are now accessible in GUI.

It really sounds like you are over complicating things…you really don’t need to add a custom integration to use global variables (that we normally just call helpers…)

I agree that we should not have to add custom integrations to use global variables.

One task that I use this for is:

  • Single click on a buttons means ‘on’
  • long click on a button means ‘increase/decrease brightness’
  • short-long (first short click, then within 2 seconds long click) means ‘change color’
    This works almost out-of-the-box on eg Homey, but impossible to create on HA without global variable (that remembers when the short click was called)

Technically: short-click task is a 2 seconds running task, increasing a variable until the end, then decreasing. Long-click tests this variable. If active, then changes color, otherwise changes brightness.