Mitsubishi AC with Wemos D1 Mini Pro

Very nice!

1 Like

Note that not all mitsubishi climates have CN105 connector. I have one (newer) model which has smaller one (also original wifi module is different), also it has 12V power output, not 5V, so original voltage regulator gets quite hot (too hot), so i replaced it with switch-mode version to prevent overheating. I can’t tell model of connector though…i just cut wires of existing (original) wifi model and connected my module to that.

Thanks. That fixed my issue!

So I have added this repo, it compiles correctly but now when it wants to push to the board it says

‘‘ERROR Error auth result: Error: Authentication invalid. Is the password correct?’’

if I do not put any line and just

Enable over-the-air updates.


  • platform: esphome

I also get error saying it needs a password

my previous config was this

Enable over-the-air updates.


  • password: “xxxxxxxxxxxxxxxx” #OPCIONAL
    platform: esphome

tried the new config from esphome website

Example configuration entry


  • platform: esphome
    password: !secret ota_password

and put


ota_password: xxxxxxxxxxxxxxxx

in the secrets file but is also not working

what am I doing wrong here ?

Just to clarify is cn105/cn100 port only available with mitsubishi electric? Is there workaround for mitsubishi heavy industries ac?

My warning was for mitsubishi electric, yes. Couldn’t say for “heavy industries” models, though, since i don’t have any.

You already get 5 in 1 order, but I can order multiple?

Sorry i was busy,

If you have a Kumo, you may have MHK1 or MHK2 thermostats that you’d like to keep using, at least for the temperature sensors. This is a github project that uses and ESP32 as a man in the middle between the MHK and the CN105 jack, just like the Kumo interface: GitHub - akamali/mhk1_mqtt: Control Mitsubishi heat pump over the CN105 port using MHK1 and MQTT

It does talk to HA via MQTT, but the nice thing is it keeps the MHK1 thermostat as a point of local control, so it can override HA if it’s down, or the wife demands a non-HA option. You can also override the temp output of the MHK with a local HA sensor. It’s a nice piece of work.

Thanks! Any specifics on the cable I need? Is there a pre wired one to buy? Is soldering required to connect to the Atom s3?

Can you use the standard project with the Airzone CN105 splitter and use the main regular project?

This is the cable that fits on m5 stack products. you then need the CN105 connector solderd on that cable its this type PAP-05V-S be sure to order the the crimp terminals

There is not much documentation there for the “airzone” unit. I’m not sure it would use the same commands as the HVAC unit, so the software may not work.

You’re right. I’ve got it coming so should know if it works.

That said the diagram they should have a wireless controller (their own other air zone product which competes with kumo cloud) and a MKH2. So given this it should work to connect an MKH2 and a modified Wemo D1 or alternative.

Overall I think you’re saying:

  • buy the M5Stsck cable
  • cut one end off it
  • connect the wires to a PAP-05V-S connector instead

A few questions:

  • I need to find this from a place I can order the cable in the USA. Trying to find that part number on another site has been a nightmare. Do you happen to have a link to a USA selling site like digikey for that cable?

  • You also mention the PAP-05V-S which I think is this connector?

  • You mention “crimp terminals” can you be more specific what you mean? What what is it for?

  • what is the wiring diagram when I connecting the cable to the new connector?

Yes thats the right connector
Crimp terminals are the metal things that go into the connector and you crimp or solder them on the cable.

Wiring diagram is the same as all the other configurations.

I am not sure if this works for you.
But when you get the atom its pretty much straight forward.
there is a sticker on it which tells you what everything is. (also there is enough documentation)

Like 5v , ground and the TX and RX terminals.
But lets be honest you really need to be confident working with this. And you can damage you airco electronics if you dont watch out.

And then you need to programm it depending you wishes.


in case anyone else is looking for the parts on Digikey (which ships from the USA):

Atom S3 Lite:

Grove Connector Cables (HY2.0-4P):

PAP-05V-S connector (connects to the CN105 port on the Minisplit):

Crimp terminals (to connect the Grove Connector Cable to the PAP-05V-S):

Good morning

I’ve been trying to solve this problem for days but I can’t figure it out:
D1 mini, connected to an MSZ-SF20VA, I can control it but I don’t have the temperature, I’m using GitHub - geoffdavis/esphome-mitsubishiheatpump: ESPHome Climate Component for Mitsubishi Heatpumps using direct serial connection, I had also tried with GitHub - echavet/MitsubishiCN105ESPHome: Mix of MisubishiHeatpump from SwiCago and esphome-mitsubishiheatpump from Geoffdavis. but I couldn’t even control the air conditioner. Suggestions?
Thank you!!

these are the logs:

12:25:13	[W]	[component:237]	Component web_server took a long time for an operation (1024 ms).
12:25:13	[W]	[component:238]	Components should block for at most 30 ms.
12:25:13	[D]	[climate:011]	'ESPHome Web fd49e5' - Setting
12:25:13	[D]	[climate:040]	 Target Temperature: 24.00
12:25:13	[D]	[MitsubishiHeatPump:416]	control - Was HeatPump updated? YES
12:25:13	[D]	[climate:396]	'ESPHome Web fd49e5' - Sending state:
12:25:13	[D]	[climate:399]	Mode: COOL
12:25:13	[D]	[climate:401]	Action: IDLE
12:25:13	[D]	[climate:404]	Fan Mode: OFF
12:25:14	[D]	[climate:416]	Swing Mode: OFF
12:25:14	[D]	[climate:419]	Current Temperature: nan°C
12:25:14	[D]	[climate:425]	Target Temperature: 24.00°C
[12:26:52][I][MitsubishiHeatPump:074]: ESPHome MitsubishiHeatPump version 2.5.0
[12:26:52][I][MitsubishiHeatPump:771]:   Supports HEAT: YES
[12:26:52][I][MitsubishiHeatPump:772]:   Supports COOL: YES
[12:26:52][I][MitsubishiHeatPump:773]:   Supports AWAY mode: NO
[12:26:52][I][MitsubishiHeatPump:774]:   Saved heat: -1.0
[12:26:52][I][MitsubishiHeatPump:775]:   Saved cool: -1.0
[12:26:52][I][MitsubishiHeatPump:776]:   Saved auto: -1.0
[12:26:52][E][component:082]:   Component esphome.coroutine is marked FAILED

and cfg:

  # Expose ESPHome version as sensor.
  - platform: version
    name: ${name} ESPHome Version
  # Expose WiFi information as sensors.
  - platform: wifi_info
      name: ${name} IP
      name: ${name} SSID
      name: ${name} BSSID
# Sensors with general information.
  # Uptime sensor.
  - platform: uptime
    name: ${name} Uptime

  # WiFi Signal sensor.
  - platform: wifi_signal
    name: ${name} WiFi Signal
    update_interval: 60s

  - source: github://geoffdavis/esphome-mitsubishiheatpump

  - platform: mitsubishi_heatpump
    name: "${friendly_name}"

      name: Horizontal Vane
      name: Vertical Vane

    hardware_uart: UART0
    baud_rate: 2400

in my opinion you are using the bare minimum to get it running.

you tried this ?

this should be part of the climate entity

      min_temperature: 15
      max_temperature: 31
        target_temperature: 0.5
        current_temperature: 0.1

And you should put the uart config outside the climate entity i think.

  id: HP_UART
  baud_rate: 2400

And look a bit beter at the yaml config from echavet and geodavis. What you set in your yaml doenst look anything on what they did.

Does anyone experience occasional “funny working” situation: i have my climate connected with esp01, without level converter. It works fine, only sometimes when i tap on “off” climate won’t really turn off, while in HA card shows that climate is off. When i tap on “off” again (or sometimes for the third time) then climate finally turns off.
It’s pretty annoying, since i have “tons” of automations and it happens that automation doesn’t turn off climate. Log shows nothing, only that it’s been turned off - only once, even though i tapped on “off” twice.
Only thing i can think would be lack of level converter, but then again i doubt that it’s the culprit, since in that case other data wouldn’t go through either.
Anything else i can look?