Mitsubishi MELCLOUD integration with Home Assistant

Hi All. Congrats on a great job developing HomeAssistant.
Are there any plans to integrate Mitsubishi Electric Air Conditioning MelCloud cloud based platform with Home Assistant?

Thanks in advance.

Not that I’ve seen. I found this in my searches, leading me to believe it is possible:

Copied from a Norwegian forum, one of the members are trying to make MelCloud work with Homeseer:

Login that returns a contextKey:
curl --data "AppVersion=´=&CaptchaResponse=&Persist=true&Email=epost&Password=passord"

Get an ID and a buildingID:
curl -v --header "X-MitsContextKey: ContextKey"

Getting all statuses from the MelCloud adapter:
curl -v --header "X-MitsContextKey: ContextKey"

Where will this go exacly ? Sorry for my ignorance and Thanks in advance!

My post was just input to get some eager developer started :wink:

I guess you can use the URLs to get json data that you can use with HA to read the state of the heat pump , but it would be difficult without a dedicated component.

be sure to +1 / vote on this feature request to get it bumped up :slight_smile:


I found out that MELCLOUD is only available in certain countries. I’m in Australia and using the Mitsubishi WIFI adapter.

started coding a MQTT poller here:

+1 for MELCloud support in Home Assistant. There is a plugin in Domoticz based on Python that maybe can be used a start?

I haven’t tried the MQTT poller, maybe that is a fully functional solution (to be able to control all functions of the HVAC like temperature, vanes, fan-speed, etc)?

P.S. I am not a developer so I am not the person to implement this

1 Like

Hi, are there any news for melcloud?

no… unfortunatly I haven’t seen anything :cold_sweat:

I had thought of a temporary solution …
to integrate the melcloud site into the home assistant in this way:

title: MELCloud

But I can not get to the site, I think the problem is https

Hi @delwinbest, does it work melcloud via Home Assistant?

No. I could not get access to Melcloud in Australia. It uses the melview API and app that comes with these devices.


I developed the MELCloud component in order to support Mitsubishi Air Conditioner in my home-assistant.

You can find it here:

I will try to send a pull-request to HA Team when I will have 5 min :slight_smile:



Hi @o0Zz

I tried your melcloud component, but it does not work

I have this error
Error fetching Cognito keyset:
15:05 components/cloud/ (ERROR)


This error is not related to melcloud component and melcloud don’t even use “cloud” component.
I think this error is related to another component, could you try to get logs from melcloud ?

default: debug
homeassistant.components.climate.melcloud: debug

Here is the debug

2018-03-25 15:20:42 INFO (MainThread) [homeassistant.components.climate] Setting up climate.melcloud
2018-03-25 15:20:42 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] Adding component: melcloud …
2018-03-25 15:20:42 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] Login …
2018-03-25 15:20:43 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] melcloud: Component successfully added !

I think everything went well, but I can not find the melcloud component

Yes, everything is going well, the component is unable to find your air conditionner.
Just after:

req = requests.get(“”, headers = {‘X-MitsContextKey’: self._authentication.getContextKey()})

Could you add below line:

And provide logs.

and now:

2018-03-25 15:38:05 INFO (MainThread) [homeassistant.components.climate] Setting up climate.melcloud
2018-03-25 15:38:05 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] Adding component: melcloud …
2018-03-25 15:38:05 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] Login …
2018-03-25 15:38:06 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] {‘ErrorId’: None, ‘ErrorMessage’: None, ‘LoginStatus’: 0, ‘UserId’: 0, ‘RandomKey’: None, ‘AppVersionAnnouncement’: None, ‘LoginData’: {‘ContextKey’: ‘13D733CBB8F64A5EAB6051EA1D1D1C’, ‘Client’: 26360, ‘Terms’: 1095, ‘AL’: 1, ‘ML’: 0, ‘CMI’: True, ‘IsStaff’: False, ‘CUTF’: False, ‘CAA’: False, ‘ReceiveCountryNotifications’: False, ‘ReceiveAllNotifications’: False, ‘CACA’: False, ‘CAGA’: False, ‘MaximumDevices’: 10, ‘ShowDiagnostics’: False, ‘Language’: 0, ‘Country’: 112, ‘RealClient’: 0, ‘Name’: ‘Michele Mercuri’, ‘UseFahrenheit’: False, ‘Duration’: 30, ‘Expiry’: ‘2018-03-25T14:08:06.06’, ‘CMSC’: False, ‘PartnerApplicationVersion’: None, ‘EmailSettingsReminderShown’: False, ‘EmailUnitErrors’: 0, ‘EmailCommsErrors’: 0, ‘IsImpersonated’: False, ‘LanguageCode’: ‘en’, ‘CountryName’: ‘Italy’, ‘CurrencySymbol’: ‘€’, ‘SupportEmailAddress’: ‘[email protected]’, ‘DateSeperator’: ‘/’, ‘TimeSeperator’: ‘:’, ‘AtwLogoFile’: ‘ecodan_logo.png’, ‘DECCReport’: False, ‘CSVReport1min’: False, ‘HidePresetPanel’: False, ‘EmailSettingsReminderRequired’: False, ‘TermsText’: None, ‘MapView’: False, ‘MapZoom’: 17, ‘MapLongitude’: 13.760831398873165, ‘MapLatitude’: 43.25111426175814}, ‘ListPendingInvite’: [], ‘ListOwnershipChangeRequest’: [], ‘ListPendingAnnouncement’: [], ‘LoginMinutes’: 0, ‘LoginAttempts’: 0}
2018-03-25 15:38:06 DEBUG (SyncWorker_0) [custom_components.climate.melcloud] melcloud: Component successfully added !

wow, I can’t see any device on your account. Did you register any air conditioner to your melcloud account ?
Can you control it from: ?