Mm sensor sensitivity configuration

Hello everybody, I’m new to home assistant, I’m using a tuya ZigBee mmwave presence sensor, when it was connected to tuya I was able to change sensitivity, distance and a few other things on the sensor, but I can’t find those options on home assistant, is there a way to access those configurations through home assistant?

Which ZigBee integration are you using? With Z2M, the options are right on the device page.

I just added the ZigBee devices through the ZigBee integration

You might need to enable quirks to see them in ZHA, but, I’ve never used it so can’t say for sure. They show up by default in Z2M.

I found a working quirk file at Add support for ZY-M100 wall mount by blakadder · Pull Request #1928 · zigpy/zha-device-handlers (
My device is a _TZE204_ztc6ggyl


Just tried z2m, but I was unable to make it work, it won’t start, i guess the problem is the adapter I’m using, can you tell what is the one you are using?

I’m using the SONOFF dongle.

What is the error in the Z2M logs?

After updating my configuration the error changed, now it seems I can’t access the dongle

Is the dongle still in use by ZHA? Is that the correct port (verify from the hardware page in settings)? You can also try by using the actual serial ID instead of the USB port.

I just disabled ZHA do I have to remove it?

I wouldn’t think so.

Seems like it found the adapter, but couldn’t connect to it, it’s a very basic adapter.

That’s the one I’m using, the sonoff that you have works out of the box or it needs to be flashed too?

I picked it up off Amazon and it worked right out the box.

The sonoff dongle arrived but the problem wasn’t the other dongle, I had to add the kind of firmware I’m using to the configuration. For anyone with the same problem, that’s how my configuration end up working.

And thanks FriedCheese for the help.

1 Like

Hi, i have a 24MmWave sensor ZY-M100-24G. I try to change the motion sensitivity using the control slider but somehow it jumps back to initial settings after a while. Do i need to do something to make the changes? I use Zigbee2MQTT

Nothing special. I’m not using any of these any more, but adjusting the sliders from the device page worked for me and the settings stayed.

Ok, i added a custom config to zigbee2mqtt like described in [New device support]: for Tuya M100S with 24G radar · Issue #18237 · Koenkk/zigbee2mqtt · GitHub . Now it works but with maximum distance of 5.5m in settings, in reality this is more or less max distance 4m. I’m not super happy about the device… distance is to short imo…

Me too! Have you fond a solution for the jumping sliders?


1 Like