Mobile App: iOS device_tracker not showing up

Hey there,

i am using the latest hass.io release and the latest beta of the new mobile App (2.0.0 (58)). I have mobile_app: and zero_conf: in my config-file and also connected the App with my hass.io installation. Most things work fine. I also have new services for notify.mobile_app_tims_iphone which is working fine. But I am not able to get the device tracker working. I have [sensor.geocoded_location_13] which is updating, but no device_tracker component is created.
I set up an empty known_devices.yaml file, before installing the app but no new device is created. Auto-Discovery is turned on.

I hope someone is able to help me.

Are you sure track is set to true? in your known_devices.yaml?

The device is not showing up in the known_devices.yaml file. I have connected the App multiple times, but it does not appear.

Okay, go through these instructions to reset the app entirely and go through onboarding again which will create the device_tracker. BTW, before you do that, make sure you don’t actually have the device_tracker. It has a crazy random name right now, like device_tracker.dfas8asm348 or something.

I followed the instructions, deleted everything and reinstalled the beta App (2.0.0 (58)) from Testflight, but no device_tracker entity was created.

This is my configuration.yaml

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: *****
  longitude: *****
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: **
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Berlin
  # Customization file
  customize: !include customize.yaml
  
  auth_providers:
- type: homeassistant
- type: trusted_networks
  trusted_networks:
    - 192.***

# Configure a default setup of Home Assistant (frontend, api, etc)
#default_config:

config:

frontend:

logbook:

map:

mobile_app:

person:
  

updater:

homekit:

history:
exclude:
    entities: 
        - sensor.lowboard_status
        - sensor.stehlampe_status
        - sensor.sonoff_status
        - sun.sun
        - switch.hdmi_5
        - switch.hdmi_4
        - switch.hdmi_0
    domains:
        - device_tracker

panel_iframe:
  tasmoadmin:
  title: Tasmota
  icon: mdi:lightbulb-on
  url: http://*****.myfritz.net:9541
# Show the introduction message on startup.
#introduction:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:

# Discover some devices automatically
discovery:
  ignore:
  - igd
  - apple_tv
# Sensors
sensor: !include sensors.yaml

hdmi_cec:
  devices:
    TV: 0.0.0.0

sun:

input_boolean:
  tim_home:
  name: Notify when Tim is home

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

system_health:

zeroconf:

Do you have any device_tracker entries at all?

no, i don’t have any device_tracker entries

i just activated an empty device_tracker: component in configuration.yaml and repeated the steps, but it did not work

I had the same problem, I solved it by uninstalling the beta app and then reinstalling again which is the last step of the cleaning between builds…
Tracker has a long name and is the UDID of the iphone

It did the above steps sseveral times, but nothing changed. The sensor.geocoded_location is updating but no device_entity is created.
I tried it with an iPad and my iPhone but neither of it worked.

No advices?

Not sure what’s going on, but obviously its something specific to your setup. You are most likely just not seeing the newly created device_tracker entity. Can you please triple check every device_tracker entity for anything that looks like a random string?

I’m sorry, but there are no entities… Do I need any component which might me loaded in default_config? I disabled default_config and added the components I need manually, as shown in my config above.

Nothing that you don’t recognize in known_devices.yaml?

It’s just an empty file…

Is it possible that it has something to do with a manual installation method? I first wanted to try the hass.io image, but when I plug in the SD-Card I just got an Error: “Ethernet not found!” although an Ethernet Cable is plugged in.
So in installed a normal raspian image and installed all recommended packages + docker following this guide: https://www.home-assistant.io/hassio/installation/
Is it possible that I need another package?

p.S. The Wifi-Setup Method didn’t work for me. Always the same Error. I used Etcher on MacOS and Windows.

I finally got it working. I updated to 0.94.4 and installed the latest iOS Version in TestFlight. I removed the Persons in the entity-register. After reinstalling the mobile app as you mentioned before the device_tracker showed up and and showed me home :slight_smile: so I’m happy now and hope to help somebody with the same problem

hello!

fixed it too

BUT:
everytime i delete the app and reinstall, homeassistant creates a device_tracker.iphone_2
device_tracker.iphone_3
… and so on

can‘t find something to delete in integrations or entity registration…

rename all the settings and it works.

greetings martin