Mobile App Notifications Groups not working

I’ve been using app notifications fine for ages, but something seems to have changed which means they all of a sudden don’t work.

I send most notfications to a group:

#Groups for Notifications
  - name: "Family Phones"
    platform: group
    - service: mobile_app_pocox5pro
    - service: mobile_app_pocox3

This used to work absolutely fine, but now, even a simple test doesn’t work:

It says it’s completed, but no notification is received

If I change out to just a singular phone it does

Has something changed in the way notification groups works?

Can you call it from home assistant?

Call it, yes

Get any notification, no

To add… calling the individual phones works

If it doesn’t work in an HA automation, it’s not going to work in NR. By any chance are you using notify to file in the group? Afaik that was the only notification change.

Right now I’m just trying to send a test notification!

I’m super confused - this group has been working for 2 years and has only recently (uncertain when) stopped working

This is by far the worst part of Home Assistant - when things just stop working for no apparent reason and then take hours to debug

1 Like

I just notice the group name is in quotes, idk if it will make a difference but they should be removed. They are not required.

  - name: family_phones
    platform: group

Have you confirmed the names of the individual services in the group hasn’t changed? You can confirm that in developer tools as well. Also test the individual services to narrow down where the problem lies.

I have - both work independently
(it actually doesn’t correctly create the group if they’re wrong - I tried adding notify. to the front of each of them on the off chance and it didn’t create the group)

Doesn’t make a difference tho - perfectly valid. See note above - the group is being created - it exists to select in developer tools. If something doesn’t match it fails to create the group

Looking at your first post and comparing to my working groups your indention where the individual services are defined need to move right by 2 spaces:

- name: family
  platform: group
    - service: mobile_app_pixel_6a

Thanks - tried that change but no difference sadly :frowning:

Some further troubleshooting - I’ve reduced the group to a single item… just my phone and it STILL doesn’t send.
However sending to the phone on it’s own does

Hmm - okay. So I think I’ve found the issue - it is actually 2 issues

My phone, the name of the notify entity didn’t match the name of the phone device… so now I’m getting them. No idea how that changed but d’oh :man_facepalming:

It’s actually pretty weird - my device is AndyPocoX5Pro (removed the name in original post but really doesn’t matter) and even in the dropdowns that are prepopulated that’s what shows.

However, if you check the notify in developer options it drops the “pro” - no idea why… all the sensors from the app still have the pro, just the notify does not
Kinda frustrating actually as now a single naming node needs a separate one for sensors and notifications

My wife’s phone however is all good. They’re appearing in the log but weren’t appearing on the phone… because she’s disabled the general notification categon :woman_facepalming:


Settings > companion app > select your server > change device name

that will reflect in the service call for the device.

Why do the two not align naturally tho? The device name is already what the notify call is, why are the sensors different?

once registered the entity names will not change by the app, the only way to correct it would be to start fresh with the app

1 Like

It’s all working now as I split the basis so I won’t do that for now, but if it stops again at some point I’ll revisit