Mobile Apps - Home Assistant Companion for Android - Pixel 6a not updating location

Rookie here - please bear with me :smiley:

I have a recent install of HA on a RPi3. Seems to be working well and I have a half dozen successful automations.

I’m having trouble getting my Pixel 6a phone to pass kits location to HA.

I have these settings in the Companion App:

and thry’re showing up in the Entity settings:

I’m set up as a person and the phone is linked to me:

So far, so good. Now, as an example, I left home for an hour or so today and drove to an appointmernt 10 miles away. The log for me, the person, doesn’t show this:

and nor does the phone log:

but the Geo Location does have some activity:

#1 shows me at home as I was leaving, #2 shows me not when I arrived at my appointment but when I was leaving and #3 shows me arriving home about 3 seconds later (!)

Clicking on the Person icon on the Overview shows incorrectly that I never left home.

Could anyone point me in the right direction? I look forward to the day when I can pay it forward!



They wrote a nice troubleshooting topic about that, perhaps it is of use: Troubleshooting | Home Assistant Companion Docs

Thanks for pointing me there. I had not seen that.

My settings do seem to be good, and the crash log does seem to be getting information:

Not sure what to look at next.

Do you also see “Location update sent successfully”? The screenshot does not show it, is it in the rest of the log?

Edit: analyzing the crash log seems to be the way to go, combined with your personal analyzing skills :wink:

Seems there’s only minimal history in the crash logs and I’ve been home all day. Going out tomorrow. I’ll check then.

Thanks for your interest/help!

It looks like the location is being updated in the Companion App:

…but somehow not back in the HA app.

What does it show in the app that is not consistent with that location update?

For reference, by default HA will show your location as Home or Away (=not home). Only when you define zones, it will show the zone names as states for your person entity as well. In addition to Home and Away.

So basically, perhaps nothing is wrong with what you are seeing?

Now I think I’m getting somewhere. I was able to capture this in the log. Any thoughts?



At that time, the companion app was unable to connect to HA. You were not on WiFi, so perhaps a bad 4G connection at that location?

another thing I would check is that your HA instance is remotely accessible, if it is not then the app will not be able to send data back home. I say this because the logs show a failure to a local IP address. When you see location update sent that means we were able to update HA, when you see the above failure that means we were not.

Thanks both of you. Going to do some testing and report back. I can remotely access HA on my phone via Nabu Casa.

I finally got things to work by pointing my Home Assistant URL to my unique Nabu Casa address rather than to Home Assistant Cloud.

I appreciate you diving in with suggestions. It’s a nice community we have here.

Just to help in case someone have the same issue later => This worked for me as well, instead of checking the Nabu Casa flag in the app I manually entered the nabu casa address of my HA and it all works now.

My symptoms were:

  • everything is working when I’m on my wifi (local connection with HA)
  • nothing is working when I’m out of the local wifi (i.e. another wifi, 4G etc.)
  • I could access to HA with the App without any problem from outside
  • All the data savers, energy savers, permissions etc were properly configured
  • In the app itself I was seeing the attributes updated but not in HA until I connect to the local wifi.

And to add up to the weird behaviour: I had the exact same configuration both on my phone and my wife’s phone, both Pixel 6, and it was not working just for me. Also, it used to worked and suddenly stopped, I don’t know when, for no reason.

1 Like