Modbus Polling slow

ome Assistant release (hass --0.51.2):

Python release (python3.5.3.1):


Description of problem:
Modbus TCP

I have successfully connected HA to communicate with my modbus device.
Polling registers takes approx 20-30 seconds, I have tested with a simple test tool and the result are received instant.

Hope anyone have a hint on solving this issue?

Have been checking out issue #8285

I am using Modbus TCP to read the data from the PLC. I was also searching for the way to set the lower poll time for the connection, but it seems that this is fixed value in homeassistant and cannot be changed (i know that in openHAB you can set the poll time) .
Fortunatelly for modbus_switches the PLC is the master, so i can have lower poll time. When i turn on/off a switch in the homeassistant, the data is almost instantly transfered to PLC.
But when the homeassistant is a master (for reading registers from PLC) it is a fixed value of poll (i think it is 30sec), so the refresh rate is very slow. It doesn’t affect my automation, because everything is done on the PLC, but it would be nice to refresh some data faster…

There need to be a way to update the scan interval for modbus.sensor.

As I see it, the modbus.sensor component uses the default scan interval of 30 seconds.

Im reading the modbus register from a light switch on my smart-house system, but a scan interval of 30 sec is a long time to wait for the light to turn on:)

I agree, that can be very frustrating. Maybe we should make a request that the scan interval for modbus would be configurable…

Unortunatelly modbus is very old and outdated standard, but for some devices there is no other way to communicate with outer world…

Modbus Outdated ?

Its the de facto industrial standard for many devices.


i know it is, i work in industrial automation… what i wanted to say is that it is an old protocol, it is OK, but it has some limitations. There are many newer protocols which are better than modbus…

Hi there, i think i found the solution. I added the “scan_interval: 2” and it is now polling my modbus binary statuses every 2 seconds.

  - platform: modbus
    scan_interval: 2

@zlabo Can you share with me your modbus configuration? I’ve PFC200 from Wago which I’m using to automate my home. I wanted to connect it with the Home Assistant using modbus but I’m having weird issues like:

  • long refresh times
  • switches automatically turning on and off