Modify pylutron

Hi there,

I’m trying to make HA work with my Lutron HomeWorks QS system. As far as i know, and i work with Lutron for more than 7 years, the only difference between the HWQS and RadioRA2, in terms of 3rd party control protocol, is that their processors respond differently on the prompt. While the RadioRA2 processors has a GNET> prompt on the telnet, the HWQS processors shows a QNET> prompt. All the commands are the same after that.

How can i modify the pylutron library so i can try if this works? I know i cannot change the docker image, and pylutron is not a component so i cannot use the custom_components folder. Is there an option for this?

1 Like

Hi, i have a homeworksqs to and searching to add or modify pylutron. but don’t know what i have to modify.
please help us.

pylutron is a library of python.


i’m trying to modify it

Have you tried to use @upsert’s Lutron custom component: https://github.com/upsert/lutron-caseta-pro? It’s written for the Caseta Pro Hub but uses the Lutron Integration Protocol over telnet, which I think is the interface for HomeWorks and Radio RA also. It may work or may need modifying for certain components, but you’ll have something to test and a place to start anyway. And you can place it in your custom_components folder for use with Hass.io. :+1:

It doesn’t work with homeworks qs. i just need to use radiora2 component, but this component use pylutron and i need to modify it because the telnet prompt of lutron is not the same as radiora2. i just need to modify pylutron

what i did was that i gave up on hass.io and moved to hassbian, so i was able to download and install pylutron locally and edited a single file, a single line, changed absolutelly one letter to make it work. The only diff between HWQS and RadioRA2 is the telnet prompt. While RA2 prompt is GNET, HWQS is QNET.

1 Like

Thank you for the post. I am also trying to get QS linked to HA. I saw exactly the same thing you experienced and gave up on hass.io and moved to Raspbian based on your post. I installed pylutron 0.2.0 (rather than 0.1.0) and changed GNET to QNET in the init.py in /usr/local/lib/python3.6/site-packages directory/pylutron. I think this is the pylutron used by HA. Added the configuration into the configuration.yaml. The xml is located and found but the HA load hangs on “connecting” to QS. Was there any other changes you found you needed to get the HA to connect and load for QS? I have quite a few devices on QS and maybe I was impatient and it needs to run a long time.

Found the issue. Of course, HA has its own libraries separate from the system python libraries and I had to modify the init.py in /srv/homeassistant/python3.6/site-packages/pylutron. Duh. Works great!!!

Revised for Hassio 0.101.x and up:

The latest pylutron package no longer times out on the prompt so the change mentioned is no longer needed to get Homeworks QS working with Lutron Radio RA integration.

OK total NOOB. I got a few minor things running in Hassio but I really want to try and accept a command sent from my Lutron QS. I’m assuming I can do that with this. I just can’t for the life of me figure out how to get pylutron running on my RPI w/ Hassio. I try to add the repository for this add in and I keep getting errors. I’m sure I’m overlooking something easy.

Would love the steps to install this.

Thanks.

I think you can now get Lutron QS running with Hassio with 2 steps.

First QS needs to allow telnet access. I did this a long time back and can go back to my steps if you need, but test it by running a telnet session into the ip address that you established on QS to access QS. You should get a QNET> prompt for id and password.

Second, once you have telnet to QS, then just installing the Lutron for Radio RA integration will get you connected. This integration automatically creates entities for all your lights. It may find some other entities but it has not found my legacy keypads/buttons etc. I use Lutron light triggers to take Hassio actions on other entities. Works great and very, very consistent.

OK, I will try this when I get home in about an hour.

Just to confirm, am I installing any integration or am I just adding it to my config like here:

Also, I have used telnet on HomeWorks before to send a command to telnet to IR converter. When sending a command to Hassio how am I listening for it in Hassio? Is there any documents with what commands In can send? Need to create 2-3 triggers that send to Hassio so Hassio can begin an automation when it see each of these.

You are just adding a config entry just like your illustration. But, be sure you can edit your config externally from Hassio in case adding the entry hangs during Hassio startup which was happening prior to 0.101

The Lutron component uses telnet to login into your Lutron QS controller then it gets the mappings/commands to your Lutron Devices and sets up entities (like lights) in Hassio. You control the Lutron lights like any other light in Hassio. An automation can monitor a Lutron light to trigger an action or the automation can take an action on a Lutron light. I only have lights and keypads on my Lutron QS so I’m unsure what other Lutron QS devices will be created and controllable in Hassio.

OK, wow that was easy! Thank you. I already have Lutron goodnight button triggering my SONOS to turn off all rooms. In coding that I was wondering if there is a wild card I can use to turn off all SONOS rooms or do I need to list them all as I have to get it to work so far. Using a wildcard would be better so if you add rooms or change names it won’t break the automation.

Have you been able to monitor a Lutron keypad for a button press in an automation like they show in the example here at the bottom of the page: https://www.home-assistant.io/integrations/lutron/

I’m not sure if my system is being the button press on the lutron keypad or I just don’t have the naming of the keypad and button in right.

I have not tried before your post. I did try lutron_event after seeing your post but have been unable to make it work. By using telnet to monitor, I can see that the keypad button press is being communicated (as is the led button) but I don’t think the pylutron component is monitoring it since these actions are coming in as DEVICE instead of OUTPUT. OUTPUT commands are successfully sent and received using the pylutron component.

UPDATE:
My Homeworks QS system uses HWI_SLIM keypads. Adding HWI_SLIM to the list does create scenes for a certain type of button: ButtonType="SingleAction" . The majority of my buttons are ButtonType="AdvancedToggle" and these don’t show up as scenes in HA. I have not yet been able to get the right ( id: name / action: single/pressed ) combination to successfully get the lutron_event to simulate a button press on any type of my keypad buttons. However, I can turn_on a scene for the single action buttons.

What are you using to monitor TELNET. Would be interested is seeing that. I was wondering if the I have the id’s correct and that would help.

Do you think we can’t read it because we are on QS and not RA. Does RA send a different event?

I also found this: Adding Lutron keypad support, unsure about how to model buttons

But I can not get it to work either. Have you tried this?

hi,

i am about to do the same with lutron homeworks QS can i am a very beginner but i have good understanding can you please provide me steps that you did to integrate it with HAssio i am gonna put a new clean install on RPI 3B+

Thanks in advance

To control and monitor the lights connected to QS, just 1) make sure you can telnet into the QS system and 2) add the lutron component into your configuration.yaml file following these instruction: https://www.home-assistant.io/integrations/lutron/

Let me know if you need additional assistance

hi, thank you for your quick reply, can you tell me way to connect to telnet is there a special cable required like usb to serial ? also the link you provided says its for radiora series i checked this says for series 4 and 5 https://www.home-assistant.io/integrations/homeworks/

so what component should be used sorry for reconfirming -

first i am gonna find the ip of home works
next i am gonna try telnet into it - is there a standard admin username or password for telnet ? i am fairly new and the lutron system was setup by professionals here my country

TIA

You can use a computer to Telnet into the Homeworks QS processor, so long as it’s on the same network. Below is a link to install Telnet:

https://social.technet.microsoft.com/wiki/contents/articles/38433.windows-10-enabling-telnet-client.aspx

As you stated, you’ll need to find the IP address of the Homeworks QS processor. You can find this in your router’s configuration page. As for the Telnet login, you’ll need to request this from whomever setup the Homeworks QS system. I believe the default login used to be:

username: lutron
password: integration

You can try those two, but it may not work.