Moen Flo - difficulty setting up integration

Had a Moen Flo installed - it works fine in the dedicated app. But the config flow for adding the integration bombs out with “unknown error” every time. I know the user name/pwd combo is ok, because if I change it to something intentionally wrong, I get the appropriate error. Here’s what’s in the logs:

Logger: aiohttp.server
First occurred: 7:27:09 AM (1 occurrences)
Last logged: 7:27:09 AM

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.10/site-packages/aiohttp/", line 435, in _handle_request
    resp = await request_handler(request)
  File "/usr/local/lib/python3.10/site-packages/aiohttp/", line 504, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.10/site-packages/aiohttp/", line 117, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 60, in security_filter_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 100, in forwarded_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 28, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 81, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 236, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 136, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/", line 180, in post
    return await super().post(request, flow_id)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 73, in wrapper
    result = await method(view, request, data, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 110, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/usr/src/homeassistant/homeassistant/", line 286, in async_configure
    result = await self._async_handle_step(
  File "/usr/src/homeassistant/homeassistant/", line 409, in _async_handle_step
    result = await self.async_finish_flow(flow, result.copy())
  File "/usr/src/homeassistant/homeassistant/", line 818, in async_finish_flow
KeyError: 'title'

Anyone experience this? thanks.

Is anyone experiencing this issue who had previously had a successful configuration of the integration? I’m wondering if this is an issue specific to the config flow, such that existing users of the integration aren’t seeing any issues, or whether it’s an issue for all users of the integration.

New user here (never been able to configure the integration). Getting the same API error, which is reported as “Unknown Error” on the UI


same error here… Flo integration - unknown error in config flow · Issue #86826 · home-assistant/core · GitHub

looks like the plugin author is working on it this weekend.

1 Like

yep, thanks. it’s fixable on your own if you can’t wait - the instructions are in that thread.

You can fix it on your own by making a custom component. You just need access to your config/custom_components folder. easiest way is probably to install the Samba share add on which gives you folder access from your computer. Then:

  1. Download the flo source code here: core/homeassistant/components/flo at dev · home-assistant/core · GitHub

  2. Open in a text editor. at line 31, change the [0] to [1]:
    a_location_id = user_info["locations"][0]["id"]

  3. open manifest.json in a text editor and add a version number (any number, it doesn’t matter), like “version”: “8.6”,

  4. upload the code to config/custom_components/flo

  5. restart and add the integration.

New to HA here, tried all of this and still getting this same error.

I’m sort of confused on how to exactly create a custom component and #4. I downloaded all of the source code, made the suggested edits but uploading the code to… exactly where? I located the file structure via Samba but there was no “custom_components” folder within config, so I just assumed I needed to create that folder, with a “flo” folder inside of that and finally move the various github flo code files straight in there? I’ve rebooted the HA machine, tried adding the integration again via the integration wizard and getting that same unknown error message.

Does your file list look like the attached?

Also, what text editor did you use to modify manifest.json and someone here Flo integration - unknown error in config flow · Issue #86826 · home-assistant/core · GitHub said there was an issue with their text editor.

it works great!.. thanks a ton!

Here is what I’m looking at. Missing the and the pycache folder. I’m using notepad as the text editor.


I had a working Moen Flo integration. I am not sure, but Core 2023.11.0 upgrade may have broke it. I noticed in Google Home the Flo linkage was broken too. The Flo app on my cell works fine. I have good indications my wifi signal is strong. The Flo integration would reload in HA but the device was still unavailable. I repeated the integration reload. I deleted the intigration/device hoping that again adding the intrgration would resolve the problem. The integration added 1 entry but no device was detected.

I have HA running in a VM and my snapshots are current. I may try to load a previous shapshot.

I went back to Google Home app and the Flo device was now gone. I re-added the Flo device in Google Home by relinking to Flo and it came back. I am lost to explain.

I looked at the fix you posted. Unfortunately, I do not know how to download the flo source code. I am no programmer and have little experienced with Github. I could not find a download link. Any guidence is appreciated.

I figured out the downloading…

I know how to download code from github and upload code to /config/custom_components/flo/. It looks like the edit directions no longer apply.