Moes ms-108wr curtain switch

Hello everyone,
I recently started in the HA world.
I purchased a controller for my moes brand ms-108wr curtain switch module. It also works with RF command.

The problem I have is that in the Home Assistant, it only appears as a switch and only works in the position to open, it does not close. :frowning:


I have already tried to flash with tuya convert to use tasmota firmware, but without success, it must have the firmware blocked for change, as I was reading Tuya started to block your equipment.

Is there any way around this situation? What I want is to control the opening of the blind in percentage, at the limit, open, close and stop.

Thanks in advance.

Did you found a solution?
I just bought the same module and I am getting the same problem.

Unfortunately I still haven’t managed to overcome this situation, I ended up buying the 2.5 shelly. But you can find the sonoff dual at a more affordable price and it also works very well with tasmota.

As for Moes, I have to find some time to open it and try to flash it.


You moes switch has a mac address starting with F4:CF:A2:* ?

Hey I got thi module, I had to do a “chip transplant” removed the WB2S and replaced that with an ESP8266 12E with tasmota on it. i’ve been tweeking with it, Im missing two things, the configuration to work as a shutter blinds roller with two relays and the communication with the RF module.
Has anyone had any progress with this?

Some progress with this module?
Algún avance con este módulo?

Thank you

Ah! Yes, well, in fact i had to order some ESP-02S / TYWE2S (they are the same form factor as the WB2S that somes with the module) chips in order to simplify things, I flashed the ESP-02S’s with tasmota, desoldered the previous one and Viola!!! This is the template i used with Tasmota:
{"NAME":"Moes WIFI+RF Curtain","GPIO":[0,0,0,544,32,33,0,0,225,0,224,0,0,0],"FLAG":0,"BASE":18}

Backlog SO80 1; Interlock 1,2; Interlock 1; ShutterButton1 1 up 0; ShutterButton1 2 down 0

SO80 1 Tells tasmota to go into ShutterMode
Interlock 1,2 binds toghether the two relays so they can act toghether but not at the same time so the motor wont burn (there are other modes but this is what worked for me and my motor).
Interlock 1 Just enables the interlock
ShutterButton1 1 up 0 Tells Tasmota that the input from button 1 which is a phisycal button is going to be up on Shutter1 (there are devices with more thatn two relays and they can be configured as Shutter2… Shutter) and 0 is just if you want to send a MQTT mesage which i dont care about that.
ShutterButton1 2 down 0 Well by now i think you can figure this one out by yourselves.

After having all this configured, you’ll have to start the tedious process of configuring your phisical shutter.
What i did is (my shutter’s motor had an autostop dial for openning and closing so i had that set up before installing the module):
ShutterOpenDuration1 70 this value (70) far exceded the time it took my shutter to open, but i needed the shutter to be fully open so i didnt wanted to take the risk to have it half way, anyway the shutter had an auto stop, so once the shutter fully opened, I stoped the the opening proces in tasmota with ShutterStop or with the GUI and then go to console and ShutterSetOpen1

Then I did ShutterCloseDuration1 70 went to the GUI and with a chronometer in hand (Smart watch or other phone or tablet can work too) as soon as i clicked the close button hit the chronometer, write down the time = it took to close and input that in ShutterCloseDuration1 <t1> Stop closing in the GUI and ShutterSetClose1

Then start openning in the GUI and ass soon as you click the button, hit the chronometer to see how much time it takes to open (usually it takes more to open than to close), write the time = to open, stop the movement in the GUI and go to console ShutterSetOpen1 ShutterOpenDuration1 <t2> and you should be all set, make the proper adjustments if needed.

1 Like

Hello! I have this module and I use Tuya integration. That works really fine! I can control position also.

Mine shows ok, but i cannot program the time its opening or closing. Any help?

Mine is the zigbee version.

Hi @ZANALOS, can you please share the yaml code used?

Hi @Vincenzo_Filho, sorry but I didn’t use yaml for this. Directly Tuya Integration steps.