Möhlenhoff Alpha 2 - climate controller

Ah, well the situation is that I have two floors to control. Each has a number of valves on a manifold with a local circulation pump. Currently, both are controlled with an HCE60 from Honeywell. Whenever there is a heat demand, the HCE60 opens the corresponding valves and activates the local pump. Unfortunately, the installer didn’t add a wired link between the two HCE60. One is located on the 1st floor, the other one is at ground level. In the current situation, our boiler is always activated, and it keeps heating the water until the return temperature is above a certain value (there is a bypass circuit that runs all the way up to the attic). It is certainly not the most economical.

We’ve coped with this for years, but as we are preparing to replace the boiler (we want to move to a full water/air heat pump solution, with storage vessel), we want to replace this old stuff with something a little more open, and sensible. So the solution we hope is offered by Alpha 2 controllers is to pair them wirelessly and have the master control the boiler (on/off) and the local circulation pump while the slave would only control the local pump upstairs and relay the boiler activation to the master.

I have solved this with two Mikrotik PWR-Line adapters - they create ethernet via your electrical line, good enough for small amount of data Alpha needs.


First of all - amazing job, I finally see the temperature, BUT. I have two hubs and 3 controllers on one and 4 on other. I see only 2 sensors from one hub and just one other hub. Tried to restart system, restart supervisor, MQTT does not pick up rest of sensors. No errors in log…

Any idees?

well that’s interesting, 5 of 7 devices now show up, once I renamed zones (removed some special characters and dashes) switched IP: second base,first base

could the numbers in zone name be fault? I have 1stfloorbath and 2ndfloor bath not showing up

UPDATE: Yes, indeed, it was numbers in zone name, once I removed numbers and special symbols, all zones showed up!

Hi @teecis
Do you have separated controllers configured in master / slave?
I have 3 pieces alpha 2 controllers, one on each floor. The ground floor controller is the master and the 2 other floors are slaves. Each controller has a dedicated Ethernet connection and IP address. However I’m only able to see the temperature of the master controller. Sometimes I see the first temperature zone of a slave. How are your controllers configured?

I started like you, but in the end I realised that master slave is only for turning on boiler or pump or eco mode. Since my heatpump does not support turning on or off and pump control, I have configured both zones as master. In app I can add 2 bars so no problem there.

Zones not showing up for me was beacause I was using spaces, special characters and numbers. Once I renamed all zones like BathroomOne, they all showed up in mqtt

Following up on the question on PAr 130. This has been resolved, the company responded promptly to my question and indicated that this is exactly the purpose of this parameter (in ‘slave’ configuration, the controller will either directly control a local pump using its own port, or forward this to the master to control the system level pump).

I’ve just installed three Alpha 2 controllers in our home, all connected via IP. I did an integration into HA, but went a slightly different route than @posixx: I wrote a Python script that represents the XML as JSON and provides a REST interface for HA.

I’m fairly new to HA, so I just run the Python script on my host operating system independently of HA. Quite some configuration of HA is required to make everything work.

Once set up, you get a standard temperature sensor reporting the actual room temperature and an input number representing the target temperature. It is possible to change the target temperature, the change is synced to the Alpha 2.

You can find the code and instructions how to configure it in HA in my github: https://github.com/andyboeh/ezr2json

Btw, I noticed that the Alpha 2 sometimes takes 15 to 60 seconds to respond to a HTTP request. So far, I haven’t been able to find a solution other than caching the values and polling in a separate thread.

1 Like

looks very cool, will test when I have time for this. how do I go about adding second EZR station?

Was that regarding my ezr2json script? If yes, just read the README:

Thanks to @tvds’ question via direct message, I ported my ezr2json script to MQTT and added support for auto discovery. This means that you just have to clone my repository (https://github.com/andyboeh/ezr2mqtt), modify its configuration file and run it on any Linux machine. No configuration on the HomeAssistant side is required if MQTT auto discovery is enabled.

Since the MQTT climate platform is used, the Lovelace ‘Thermostat’ card can be used as well!

This is not a home assistant component or addon! It works completely independently of HA. It can be run as Home Assistant addon. Think of it as a software gateway that translates Alpha 2 <-> MQTT

NB: It’s a really quick solution without much testing. YMMV.

Well that’s some really great news!!! Many thanks! :slight_smile: :star_struck:
Will test it tomorrow.


I have running home assistant on a raspberry pi
How can i add my alpha 2 thermostat to it?

If you read through this thread, you might find several solutions:

  • alpha2mqtt by @posixx
  • ezr2json by me
  • ezr2mqtt by me

Btw, ezr2mqtt now supports visualization of heating/cooling mode and auto-creates one sensor per actor that shows the percentage (if supported by the Alpha 2, else just 0% or 100%). Thanks to @tvds for the idea and testing!

1 Like

I am completely new to Home Assistant (and Linux), so please forgive my ignorance.
I have Home Assistant Container (not OS) running on Ubuntu 20.04.
@andyboeh, How should I install ezr2mqtt and make the integration with HA when not using HA OS?


Simply clone the repository, configure ezr2mqtt.yaml to your needs and run ezr2mqtt.py. If you run Arch Linux, you can also use the supplied PKGBUILD to build a native package.

No configuration on the home assistant side is required apart from enabling the MQTT integration (as long as you don’t disable MQTT auto discovery)

Previously I used @posixx container, but its not available for download, so I am trying ezr2mqtt.

Unfortunatelly I don’t really understand how to install this on hass on raspberry pi. I copied all the data to addons/ezr2mqtt and added ezr2mqtt.yaml to config. I edited to ezr2mqtt.yaml host to Nothing is discovered.

What am I missing?

EZR01A3AF.lan in configuration - do these need to be taken from my Alpha2 or just random something?


You can add my repository to the addon store and install the addon from there:


can you also make this available via “Addon Store” → “Repositories” ?

I’m sorry, I can’t support Addon mode: My Home Assistant ist dockerized and ezr2mqtt is running natively. As I cannot test it, I can only provide the files as they are.