Möhlenhoff Alpha 2 - climate controller


You can add my repository to the addon store and install the addon from there:


can you also make this available via “Addon Store” → “Repositories” ?

I’m sorry, I can’t support Addon mode: My Home Assistant ist dockerized and ezr2mqtt is running natively. As I cannot test it, I can only provide the files as they are.

This is the IP address or host name of your Alpha 2.

Your addon gives you quite a lot of output, especially if you enable “debug” in the config file. Do you get any sensible output?


a small typo, should be GitHub - posixx/hass_addons (missing an “s” in the end)

Thanks fot your involvment, resolved with suggestion from @posixx

For those in the future struggling (i.e. me, after reinstall of home assistant) with ezr2mqtt.yaml config (it was not self explanatory since creator used names instead of ip):

  - host: IP Address of Alpha2 base
    name: name of this base
  host: IP address of mqtt server
  port: 1883
  debug: false
  username: configure only if mqtt has user/pass
  password: configure only if mqtt has user/pass
  discovery_prefix: homeassistant
  topic: alpha2
  interval: 60

Sorry for that, but host is - for me - self explanatory. I try to use host names wherever possible, as I have a central configuration point (router) for that.

Please format your response with code tags.

not for noobs : )
thanks for the integration, works great now

I am a little confused (sorry just started with HA a few days back)

Are those now 2 solutions? from AndyBoeh and Posixx ? what are the differences?

Exactly. I can only speak for ezr2mqtt, the features are as follows:

  • Home Assistant auto discovery
  • Current temperature (get)
  • Target temperature (get, set)
  • Auto/Off state (get) - powering on is not supported via the XML API
  • Auto/Day/Night mode (get, set)
  • Cooling mode (get) - limited testing only
  • One sensor per actor reporting its percentage (get)

I would Test it for you if you would create it. Or a HACS Version?


Thanks, but that takes too much time. Apart from the initial bring up, somebody also needs to support it.

HACS is completely different and requires a rewrite from scratch. I would love to be able to offer a HACS version, but then this means moving from MQTT to native types. Once construction work has finished in our home, I may start with this (NB: this has a timescale of one year+).

I implemented the XML interface for another Smart Home solution and was in contact with Möhlenhoff what actuall some attributes mean (since a “Stellantrieb” has only 0 or 1 as state)

The relevant xml attributes are ACTOR, STATE and ACTOR_PERCENT which represent the PWM Cycle, the info if heating or cooling is actually requested from the Zone (Heizanforderung) and finally if the actor (Stellantrieb) is triggered (bestromt ja nein).
At least the info is the actor is triggered (if I remember that was the STATE attribute) is a nice information as you us this e.g. in Grafana to visualize when heatzones really were heated.

If you are interested I can forward the mail answers from them (German) via PM.

To toggle between Cool and Heat mode is something interesting.
Any reason why you only implemented it with get yet?

There are two different possibilities: Either, the heating system (heat pump) switches between heat/cool and tells the Alpha 2 of this, or it’s the other way round, i.e. the Alpha 2 decides on heat/cool and tells the heat pump to switch mode (Change Over). I do not have a heat pump (yet), so I can’t test either, but one user reported that reading this status works.

In my current system I just have an automation which controls both devices seperately.
So If I change a helper entity from e.g. COOL to HEAT
the automation updates the EZR via the changes.xml to switch to the respective mode and seperately the automation changes the heatpump to switch to the respective mode.

So the logic is fully in my smarthome application.

I have the ezr2mqtt running and can see with MQTT Explorer there where 2 topics created.
I have auto create entities on in Mosquitto … however no new entity is created and I dont find a way to do so. How can I retrigger the discovery messages?
I already tried uninstalling, restarting of the mqtt and/or ezr2mqtt aswell as deleting the topics manually.
no success

Also I see on MQTT Explorer the step is defined 0.1
Since the EZR only allows 0.2 … is there way I can change the step to 0.2 ?

Did you change the auto discovery prefix in Home Assistant’s configuration to “fbh”? If not, please change it back in the ezr2mqtt configuration to “homeassistant” - see MQTT Discovery - Home Assistant

You need to edit the python script to change the step size - I did not know that only 0.2 was supported and I’m actually quite certain that my Alpha 2 supports a step size of 0.1.

uh ok didnt know is must be homeassistant.
I will try and see if it works then :slight_smile:

Current Temp (IST Temp) = 0.1
Target Temp (SOLL Temp) = 0.2
If I use the controller (Raumbediengerät) it only allows stepping 0.2 and if I use the UI from EZR Web itself I technically can enter e.g. 22.1 but it will automatically change this to 22.2 just a moment later

If yours really allows 0.1 as Target Temp steps I would be interested what firmware version you have.


Well, I do need some help!
I am newbie on HA, however over the last days, Imlearned a lot and have already installed several integrations and addons. However, I do struggle with the ezr2mqtt.
I copied all files to the addons directory and copied the yaml file to the config, however no addon or integrations shows up. I also tried to copy everything into the custom_components folder, didn’t help either. (and yes I did restarts)
I also changed the Ezr2mqtt.yaml to include the ip-adress of my Alpha2 and the host name of the mosquito browser.
Other mosquito Protokoll I do see some repeating entries


1635229340: New connection from on port 1883.
1635229340: Socket error on client , disconnecting.
1635229460: New connection from on port 1883.
1635229460: Socket error on client , disconnecting.
1635229580: New connection from on port 1883.
1635229580: Socket error on client , disconnecting.
1635229700: New connection from on port 1883.
1635229700: Socket error on client , disconnecting.
1635229797: Socket error on client 7xh0LpiH7ScQw65L3gaMLe, disconnecting.
1635229807: New connection from on port 1883.
1635229807: New client connected from as 0nba39bMsZTwFUwf8W9MOo (p2, c1, k60, u’homeassistant’).

Which are quite strange, as is not part of my network range ( which is 192.168.177.xxx)

After trying a lot, I am quite lost. Anyone able to take my hand and guide me through the process?