MOPAR still does not work - error during initialization

I have reached out to the thread for github and tried posting in the forum, creating this new entry because as of build 104 MOPAR still does not work… clean install.

In the logs I see the following:

Error during setup of component mopar
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 174, in _async_setup_component
    component.setup, hass, processed_config  # type: ignore
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/mopar/", line 68, in setup
  File "/usr/src/homeassistant/homeassistant/components/mopar/", line 113, in update
    self.tow_guides[index] = motorparts.get_tow_guide(self._session, index)
  File "/usr/local/lib/python3.7/site-packages/motorparts/", line 92, in wrapped
    return function(*args)
  File "/usr/local/lib/python3.7/site-packages/motorparts/", line 106, in wrapped
    return function(session, *args)
  File "/usr/local/lib/python3.7/site-packages/motorparts/", line 164, in get_tow_guide
    'vin': profile['vehicles'][vehicle_index]['vin']
  File "/usr/local/lib/python3.7/site-packages/requests/", line 897, in json
    return complexjson.loads(self.text, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/simplejson/", line 525, in loads
    return _default_decoder.decode(s)
  File "/usr/local/lib/python3.7/site-packages/simplejson/", line 370, in decode
    obj, end = self.raw_decode(s)
  File "/usr/local/lib/python3.7/site-packages/simplejson/", line 400, in raw_decode
    return self.scan_once(s, idx=_w(s, idx).end())
simplejson.errors.JSONDecodeError: Expecting value: line 2 column 1 (char 1)

I see your open issue is waiting on you providing more details, and has been since two days after you opened it :wink:

1 Like

Same issue here and has been this way since at least April of last year. I’ve even tried clean installs of HA with mopar being the first component added and get the same result. I posted my log to your git thread.

1 Like

It looks like 105.5 fixed the issue for me.

Same issue here - still doesnt work since 105.5

See this comment on the open issue:

it currently doesn’t have a code owner

There’s nobody currently in a position to fix the problem. Somebody who uses MOPAR and can code in Python needs to step up and resolve this.

1 Like