It would be nice if the zone variable “passive” could be split into one variable for each behaviour. Currently the docs states this:
passive (Optional): Optional boolean to only use the zone for automation and hide it from the UI and not use the zone for device tracker name. Defaults to false.
At a glance it looks like this varable changes three things, but it’s only two: UI visibility, and device tracker state changes.
So why not remove passive and split it into two variables like this instead:
- tracking (optional, defaults to true) - device tracker state
- ui_visible (optional, defaults to true) - map zone visibility
Setting both to false gives the same behaviour as the current passive: true
and it would be possible to tweak the behaviour as needed.