Mosquito broke Node Red

What does this mosquitto error log mean:
2023-12-06 01:32:58: New connection from on port 1883.
error: received null username or password for unpwd check
2023-12-06 01:32:58: Client nodered_37c7982920a6df2a disconnected, not authorised.
My Node Red stopped working, so I looked at logs and its always matt, so looked at moswitto logs and hot that. I thought local users didn"t need credentials. That local up ending in 227 is my HA

incidentally Zigbee2MQQT Works (map and open/closed door)

have tried deleting and reinstalling. Same error. Settings file must persist.

Have you tried searching for that error?

Newer versions of mosquitto don’t allow anonymous access for security reasons, so you need to enable it explicitly.

No, I’ll try just that error search now before sleep.

I thought anonymous access was allowed for Home assistant users who are logged in because they need a username and password to get that far, but everyone needs them? And I don’t get how Zigbee2MQTT still works but not Node Red and I just tried an automation involving MQTT and it works. It just seems like Node Red.

Edited to add. It’s the home assistant operating system I am using. I think it automatically creates a user for Mosquito.

I have the same issue. When I googled it last weekend, I think it was introduced in a recent update?

2023-12-06 06:33:43: New connection from on port 1883.
2023-12-06 06:33:43: Client <unknown> closed its connection.

On just Node Red or everything?

Whenever I google the error I get mentions about it generally not working, not it just being one program. That’s the bit I don’t get. Unfortunately I am running the home assistant operating system so file exploration isn’t easy but I think I need to delete the setting in the Node Red settings file so it doesn’t try to connect.

Thus is the error in node red
[info] [mqtt-broker:Home Assistant] [info] [mqtt-broker:Home Assistant] Connection failed to broker: mqtt:// That is my IP and port