Mosquito MQTT connects but does not allow publish or subscription


Long time reader, first time poster.

I have a setup where a python program running on an RPI sends around 30 messages (QOS 0, Retain false) to a Mosquito MQTT at set intervals of 15 minutes. MQTT is running as an addon to Homeassistant which is itself running on a separate RPI. This setup worked very well for about 10 days after which point I decided to snapshot migrate the Homeassistant RPI from SD Card to SSD retaining all the IP addresses I had before. After migration I noticed that the message throughput was intermittent to the point were the messages were only getting through about 1/6 of the time. When I tried using MQTT Explorer I could see that I could connect but all I saw was the IP address of the server in the display window eg no topics or messages were displayed including $SYS topics.

The configuration of MQTT was standard (no config changes made by me) and there was nothing I could see in the MQTT logs that would indicate an error. Indeed, the logs confirmed that a connection from a new client (Both my python script and MQTT Explorer) had been successfully made.

Testing from Homeassistant MQTT UI allowed both publishing and subscription .

After much rooting about I added a user to the MQTT config and this seems to have cured my problem for now.

certfile: fullchain.pem
  active: false
  folder: mosquitto
keyfile: privkey.pem
  - username: mqtt
    password: mqtt
require_certificate: false 

I am new to Mosquito and MQTT so I am not sure whether this is an issue on my config/understanding or a quirk of my storage migration.

Mosquito MQTT : 6.0.1
Home Assistant : core-2022.4.7
Supervisor: supervisor-2022.04.0