Mosquito update 4.1 - ACL messages in logs

Just upgraded, all working ok except my logs have lots of messages to do with ACL check. Anything to worry about?

1552293232: |-- mosquitto_auth_acl_check(…, client id not available, mquser, tele/sonoff9/STATE, MOSQ_ACL_WRITE)
1552293232: |-- aclcheck(mquser, tele/sonoff9/STATE, 2) CACHEDAUTH: 0
1552293232: |-- mosquitto_auth_acl_check(…, client id not available, mquser, tele/sonoff9/SENSOR, MOSQ_ACL_WRITE)
1552293232: |-- aclcheck(mquser, tele/sonoff9/SENSOR, 2) CACHEDAUTH: 0
1552293232: |-- mosquitto_auth_acl_check(…, client id not available, mquser, tele/sonoff9/SENSOR, MOSQ_ACL_READ)
1552293232: |-- aclcheck(mquser, tele/sonoff9/SENSOR, 1) CACHEDAUTH: 0

Same but it works so…

1 Like

It’s filling the log though. It is possibly something to do with access control lists. It may be looking for the client/user in a list but it doesn’t exist. I think they list what topics can be published by the client/user.

Just found the docs - see ACLs at

its filling up the addon logs, but it works .

As per the instructions it should run when customize set to active but looks like it is checking ACL list even when set to false.

mosquitto_auth_acl_check(…, client id not available,

"customize": {
    "active": false,
1 Like

Discovery feature seems to be broken too.

I have these too after updating Mosquito an hour ago from 2.0 to 4.1, and all my MQTT devices are ‘unknown’ in the HA States view in my case…
mosquitto_auth_acl_check(…, client id not available, myhomemqtt, tele/sonoff_bridge/RESULT, MOSQ_ACL_WRITE)
Any suggestion other than RTFM ?

1 Like

What is the username you are using for the Mqtt clients to login with?

On port 1883

Do I now need to have the mqtt user name list in HA’s configuration GUI users list (below ‘integrations’) ?

No, not necessary if you have one configured in the add-on. There were some usernames that are not allowed in v4 onwards but yours should be ok. Do you have errors on the clients?

Yes I have had one (username/pw) in the addon since the component was installed a year ago.
I just tried adding it in the GUI but have not restarted HA to see what happens.

Sorry I’m not sure what you meant by errors on clients, but all three mqtt devices (two sensornodes and one Sonoff RF Bridge with Tasmota FW) are unknown in HA and also don’t respond to HA (lights on the nodes etc) the bridge tries to report to HA but that just generates the message above each time a door switch or PIR is triggered.

In the Tasmota web interface, go into the console and see if you are getting error messages there.

It seems not. Just doing a reboot and a retest, but all the console messages in the last hour look normal.
Edit: After restarting the RF Bridge same result, no console errors.
Edit2: Rebooting the RPi via hassio

Edit3: mqtt is back up. My problem was still having the mqtt broker setting in configuration.yaml like pre-integration.
I also took out my old username and password from the mosquito component config, and setup a new HA user with those strings instead.
Might still have a couple of questions but that can wait till tomorrow…

1 Like

Ok, I got it working after deleting the config from the yaml.
But it looks like anonymous publishing doesn’t work now. My client connects but nothing comes in on the topic. My other client that connects with user and pass publishes fine.

1 Like

So what is the solution…

Before update to migrate setting to web interface and delete settings from config file?

This won’t help with the ACL entries in the log. We either need to make an ACL file or wait for the feature to be disabled by default.

So solution is not to update from 4.0 to 4.1…

It just fills the log, it still works ok for me

and how are your setting … in config or directly via GUI?
Can you paste your code from GUI or config (if you have still there) which is working in 4.1…