Mosquitto Broker won't start "redirfd: fatal: unable to exec fix-attrs: Exec format error"

Hey guys,

we had a power loss a couple of days ago and since then my mosquitto add on won’t start anymore.

The log is as followed:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
redirfd: fatal: unable to exec fix-attrs: Exec format error
[s6-init] ensuring user provided files have correct perms...exited 126.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

I’ve tried to reinstall the add-on (mosquitto and terminal server), restarted, etc. etc. but nothing worked.

Any ideas how I can fix it?

Thx in advance,

best regards

Exec format error

Usually caused by trying to run a Docker image on the wrong platform (like x86_64 on armhf).

Strange. Sys-Log has the following output:

22-01-29 21:43:43 INFO (SyncWorker_0) [supervisor.docker.addon] Starting Docker add-on homeassistant/armv7-addon-mosquitto with version 6.0.1

I didn’t change anything on purpose so I don’t understand why this error happens now…